imessage sync between phone and mac

Kawawolf

macrumors newbie
Original poster
Jan 24, 2018
20
5
Upstate NY
Pretty sure I haven't run into a message that already deals with this issue.

Basically I have an SE that I kept on 9.0 until ios12 came out. It synced with my mac on High Sierra with no issues. After I switched to 12, it quit syncing with my mac. My imessages on my mac are from 9/17/18 and no later than that. I've upgraded to Mojave in the meantime, logged out of imessages and logged back in, but nothing seems to work to get it to "see" that I have had plenty of new messages received and sent since that day.

I'm pretty sure I didn't turn anything off/on when upgrading to 12, but it is possible something was changed and I never activated it. Anyone else have this issue and figured out what the trick is? Thanks!
 

atlchamp

macrumors 68000
Jun 19, 2012
1,950
1,153
Atlanta
Pretty sure I haven't run into a message that already deals with this issue.

Basically I have an SE that I kept on 9.0 until ios12 came out. It synced with my mac on High Sierra with no issues. After I switched to 12, it quit syncing with my mac. My imessages on my mac are from 9/17/18 and no later than that. I've upgraded to Mojave in the meantime, logged out of imessages and logged back in, but nothing seems to work to get it to "see" that I have had plenty of new messages received and sent since that day.

I'm pretty sure I didn't turn anything off/on when upgrading to 12, but it is possible something was changed and I never activated it. Anyone else have this issue and figured out what the trick is? Thanks!
call apple support. this is a known issue with sync across devices.
 
  • Like
Reactions: Rhonindk

Kawawolf

macrumors newbie
Original poster
Jan 24, 2018
20
5
Upstate NY
Also been having the non sync issue the last few days
Just replying because I was able to get it fixed when I called Apple Care.

1.) Log Apple ID out of imessages in your Mac.
2.) Restart the Mac.
3.) On your phone, go to settings and Messages.
4.) Make sure under Send and Receive you have it checked to both your phone number and your Mac computer.
5.) On your Mac, log back into your Apple ID
6.) Send yourself a test message and see if it works.

It will not update all the messages that were sent between the time it stopped syncing to the time you get it to start, but going forward, all should be good. :)
 

YatBob

Contributor
Apr 23, 2014
238
62
Louisiana
Just replying because I was able to get it fixed when I called Apple Care.

1.) Log Apple ID out of imessages in your Mac.
2.) Restart the Mac.
3.) On your phone, go to settings and Messages.
4.) Make sure under Send and Receive you have it checked to both your phone number and your Mac computer.
5.) On your Mac, log back into your Apple ID
6.) Send yourself a test message and see if it works.

It will not update all the messages that were sent between the time it stopped syncing to the time you get it to start, but going forward, all should be good. :)
Thanks, I did those steps last night, I also signed out of iCloud and back in, all seems to be working for now
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.