iMessage sync

Discussion in 'iOS 5 and earlier' started by Telp, Oct 12, 2011.

  1. Telp macrumors 68040

    Telp

    Joined:
    Feb 6, 2007
    #1
    So I've been using ios 5 for about a week now and I can't figure out how to get my iPad to sync with the iMessages that I write with my phone to someone's phone number. Is there anyway to connect my iCloud or iPad with my phone so I can get all my imessages, and not just the ones I'm sending to appleIDs?
     
  2. vettori macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #2
    I don't think messages are synced between devices. Each device only has the messages it has sent/received with its configured account.
     
  3. nampramos macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #3
    You need to had either phone numbers or e-mail addresses to both iMessage settings I think.
     
  4. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #4
    I think the way you do it is by using your itunes account for iMessage so that you can sync between your devices. Go to Settings> Messages> Receive at> Caller ID> your email
     
  5. aajeev macrumors regular

    Joined:
    May 7, 2008
    #5
    Yea, I thought about this a while back. I think, all iMessage is routed through an AppleID (and I assume that's how apple is by passing the text message system). So assuming all iPhone users has an AppleID, and all iMessages are routed via AppleID then I don't think you would have problem getting all the "iMessages" to sync on your iPhone, iPad etc... However, I don't think you are going to be able to get those text message (via phone number) sync to your advices other then (iPhone).

    I guess I could see that been a potential problem, but then again it depends, my fiancé, most relative and friends has an iPhone so I guess it won't be much issue for me. But yes I can see your concern.
     
  6. Telp thread starter macrumors 68040

    Telp

    Joined:
    Feb 6, 2007
    #6
    That's not exactly the whole picture though. You can iMessage a phone number, and that is what I want to sync. It is still an iMessage, but its not going (at least directly?) through an appleID. I guess I'll just have to full around with it and see what happens.
     
  7. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #7
    Tell people do add your apple ID to your contact info on their idevices and receive messages on your apple ID rather than your number. That way it should sync but I havent tried it yet
     
  8. craig4568 macrumors member

    Joined:
    Jun 25, 2010
    Location:
    North Yorkshire
    #8
    got it

    i dont think it can be done been messing for hours now
     
  9. BHP41 macrumors 6502a

    BHP41

    Joined:
    Jul 21, 2010
    Location:
    United States of America
    #9
    Mine syncs perfect. The contacts that I'm imessiging with only have my phone number.

    Do you have all of your info in your contacts? What I mean is I have all my info under my name in contacts. Not sure but I've used it all last night and this morning and it has worked flawlessly. Now if it will sync with iChat would be the topper.
     
  10. Frosticus macrumors 6502a

    Frosticus

    Joined:
    Oct 4, 2010
    Location:
    Bristol, UK
    #10
    I had this problem. Here is what I did to fix it...

    On both devices, under the Message/iMessage settings, first ensure the same Apple ID is being used on both devices.

    On your iPhone it will say "You can be reached for messgaes at: <your number>", and on the iPad it will say "You can be reached for messgaes at: <your Apple ID>".

    I found taht so long as both were set using the same Apple ID and both had a common email address where messages could be recieved, it worked fine.

    One other thing to note is that I had to delete an existing SMS thread on my iphone before the iMessage thread to the same contact would sync properly.

    I hope this helps! ;)
     
  11. Akira1980 macrumors 6502

    Akira1980

    Joined:
    May 27, 2007
    Location:
    San Diego
    #11
    Under message settings, use apple ID as your call ID. (not your phone #)
     
  12. ddehr026 macrumors 6502

    Joined:
    May 1, 2010
    #12
    iMessage not syncing between iPad and iPhone

    Has anyone else run into this issue? My iMessages are only showing up on my iPad. I have everything turned on in both and using the same email addresses to receive iMessages....
     
  13. corrado7 macrumors regular

    corrado7

    Joined:
    Mar 26, 2008
    Location:
    Atlanta
    #13
    Still not working for me :(
     
  14. Frosticus macrumors 6502a

    Frosticus

    Joined:
    Oct 4, 2010
    Location:
    Bristol, UK
    #14
    This is not necessary.

    I use my phone number as iMessage caller ID on my iPhone and my email address as caller ID on my iPad and imessages sync just fine.
     
  15. corrado7 macrumors regular

    corrado7

    Joined:
    Mar 26, 2008
    Location:
    Atlanta
    #15
    Hmm i tried this but the messages will only come to my iphone not my ipad... any other suggestions?
     
  16. Chrisbkreme macrumors member

    Joined:
    Jul 21, 2011
    #16
    I've tried all of the above as well, none of it works for me. I get everything on my iPhone, but nothing on my iPad 2.
     
  17. sooner518 macrumors member

    Joined:
    Oct 5, 2011
    #17
    i had to set my CallerID on my phone ("Settings>>Messages>>Receive At>>CallerID") to my email address. now they sync perfectly.

    before, I had the callerID set to my phone number. If I sent a message to a friend from my phone, it would show up as one contact, and when I sent a message from my ipad, it would show up as coming from a completely different contact.
     
  18. slapshot macrumors member

    Joined:
    Feb 22, 2009
    Location:
    Central Ohio
    #18
    I am trying to send an iMessage from my iPad to my wife's iPad and I can't seem to get it work. Whenever I bring up her email address on my iPad, it says it is not a registered with iMessage. How do you do that?
     
  19. Mobile923 macrumors 6502

    Joined:
    Sep 20, 2007
    Location:
    New York, NY
    #19
    did the trick!
     
  20. Mike Teezie macrumors 68020

    Mike Teezie

    Joined:
    Nov 20, 2002
    #20
    I'm sure that this is a stupid question - but if you set your phone this way, can people without iPhones still text you at your number?
     
  21. Chrisbkreme macrumors member

    Joined:
    Jul 21, 2011
    #21
    I still cannot get my iPad to sync with my iPhone with iMessages. Nothing shows up on my iPad.
     

Share This Page