iMessage Syncing Problems

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TheOnlyColors, Mar 24, 2012.

  1. TheOnlyColors macrumors newbie

    Joined:
    Mar 24, 2012
    #1
    Hi,

    I'm having a bunch of issues getting my iMessages to sync across my iPhone 4s, iPad 2, and Macbook Pro. I'll start by saying all are running the most up-to-date software and nothing is jailbroken. I used to be an Android user so all of my contacts are set up on all my devices to sync from my Google account to my address book. Here are the problems I'm having:

    1) When I text iPhone users, iMessages work like they should except for with one friend. He has an iPhone but it sends everything as a text and we both have iMessages enabled. Any ideas here?

    2) My iMessages won't sync with my iPad. I have it set up so I receive iMessages at my email address that is also my Apple Id. No clue why this won't work correctly because I have a friend who has it set up the exact same way but he doesn't have any problems. iMessages are set up to be received at both my phone number and Apple Id on my iPhone.

    3) On my Macbook, the only iMessages that I receive are those from contacts I've created since I got my iPhone. I think this is obviously happening because they're being created as contacts from my phone and not from Google. However, all these contacts still show up under my Google contacts too. That makes me think there's something strange going on because clearly the contacts sync both ways between Google and my Apple address book so they should all have the same behavior.

    4) Lastly, anytime I send an iMessage from my Macbook it shows up to the other person as it being from my email. Is there any way to get these to show up as being sent from my phone? Also, since I'm receiving a few contacts' iMessages on my laptop, if I respond to them on my computer will it show up from my phone number or from my email? It seems like it would send from the email but wouldn't that create a new messages thread? That would be annoying to send a text to someone's phone but then their response comes in from a different source.

    Sorry for the novel and thanks for all help.
     
  2. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #2
    Not sure if this will help, but give it a try...

    On your iPhone, in Settings > Messages > Receive at ... have your iPhone number as primary and add your email(-s) as secondary. On your other iDevices, have the email(-s) listed.

    You may need to iMessage from your non-phone devices (iPad or Mac) once to set it up internally on the device. After that, they should all sync... hopefully.

    Worked for me - iPhone to iPhone only showed up on my iPhone, but once I sent an iMessage to the same person via iPad, it showed up on iPhone and iPad from then on. However, note that if one is off or "alseep" at the time, the missed iMessages won't be downloaded the next time you open the Message app.
     
  3. TheOnlyColors thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #3
    Thanks. I posted the same question elsewhere and I was getting more responses. I figured I'd link the discussion to this thread.

    Other Discussion Thread
     
  4. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #4
    Not sure if this will help, but give it a try...

    On your iPhone, in Settings > Messages > Receive at ... have your iPhone number as primary and add your email(-s) as secondary. On your other iDevices, have the email(-s) listed.

    After you iMessage from iPhone to iPhone the first time to a contact, you may need to iMessage from your iPad or Mac once to set up the connection with that contact. After that, they should all sync... hopefully.

    Worked for me - iPhone to iPhone only showed up on my iPhone, but once I sent an iMessage to the same person via iPad, it showed up on iPhone and iPad from then on. However, note that if one is off or "alseep" at the time, the missed iMessages won't be downloaded the next time you open the Message app.
     
  5. TheOnlyColors thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #5
    Thanks. Won't that cause a second thread to start on the recipient's phone? I know it's not that big of a deal but it would be nice to not have to deal with that. I just find it strange how the 3 or 4 new numbers I have all send straight to all my devices even though they only have my number and not Apple Id.
     
  6. Tinmania macrumors 68040

    Tinmania

    Joined:
    Aug 8, 2011
    Location:
    Aridzona
    #6
    Keep in mind iMessage on OS X is in beta. Strange things have happened with it.

    As for sending from iMessage on a mac from a phone number I don't think that will ever happen. There is no way for the mac to send as a text if it failed.

    Also, I used to have my email address as caller ID on my iPhone but changed it back to the phone number. I was missing messages that could not go through iMessage. This would happen when I lost internet for a while--either in a low signal area or if on wifi the wifi network was having issues. Normally the other sender, if using an iPhone, would then send as text and I would still get it, albeit a few minutes late. But to my email address it would just fail on their end.

    Even now if your iMessage conversations to iPhone users occasionally "turn the unwanted green" (lol) then they would not have worked at all if sent to email address.




    Michael
     
  7. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #7
    It hasn't started a second message on either iPhone or iPad for me. The iMessage stays as a single thread on both. The iPad thread may be missing the first messages that were transmitted iPhone to iPhone (before I sent one using the iPad). If you don't delete the thread, future iMessages will just be added to this same thread, even if there's a couple days or weeks in between messages.
     

Share This Page