iMessage Syncing Problems

TheOnlyColors

macrumors newbie
Original poster
Mar 24, 2012
6
0
Hi,

I'm having a bunch of issues getting my iMessages to sync across my iPhone 4s, iPad 2, and Macbook Pro. I'll start by saying all are running the most up-to-date software and nothing is jailbroken. I used to be an Android user so all of my contacts are set up on all my devices to sync from my Google account to my address book. Here are the problems I'm having:

1) When I text iPhone users, iMessages work like they should except for with one friend. He has an iPhone but it sends everything as a text and we both have iMessages enabled. Any ideas here?

2) My iMessages won't sync with my iPad. I have it set up so I receive iMessages at my email address that is also my Apple Id. No clue why this won't work correctly because I have a friend who has it set up the exact same way but he doesn't have any problems. iMessages are set up to be received at both my phone number and Apple Id on my iPhone.

3) On my Macbook, the only iMessages that I receive are those from contacts I've created since I got my iPhone. I think this is obviously happening because they're being created as contacts from my phone and not from Google. However, all these contacts still show up under my Google contacts too. That makes me think there's something strange going on because clearly the contacts sync both ways between Google and my Apple address book so they should all have the same behavior.

4) Lastly, anytime I send an iMessage from my Macbook it shows up to the other person as it being from my email. Is there any way to get these to show up as being sent from my phone? Also, since I'm receiving a few contacts' iMessages on my laptop, if I respond to them on my computer will it show up from my phone number or from my email? It seems like it would send from the email but wouldn't that create a new messages thread? That would be annoying to send a text to someone's phone but then their response comes in from a different source.

Sorry for the novel and thanks for all help.
 

MikeCase

macrumors member
Aug 19, 2009
70
0
Melbourne, FL
1) When I text iPhone users, iMessages work like they should except for with one friend. He has an iPhone but it sends everything as a text and we both have iMessages enabled. Any ideas here?
I had a friend who had iMessage disabled so everything we sent was as text message. I also had a different friend who had an iPhone but was running iOS 4.2.1 so they didn't have iMessage. Do you know if either of these apply to your friend?

4) Lastly, anytime I send an iMessage from my Macbook it shows up to the other person as it being from my email. Is there any way to get these to show up as being sent from my phone? Also, since I'm receiving a few contacts' iMessages on my laptop, if I respond to them on my computer will it show up from my phone number or from my email? It seems like it would send from the email but wouldn't that create a new messages thread? That would be annoying to send a text to someone's phone but then their response comes in from a different source.
I don't think you can set iMessage to show as sent from your phone from any other device. Once I set up my "Caller ID" to be from my email address on all my devices, any message from any device shows up in the same message thread. I'm not sure if that's what you mean so I'm sorry if I'm misunderstanding.
 

TheOnlyColors

macrumors newbie
Original poster
Mar 24, 2012
6
0

aristobrat

macrumors G5
Oct 14, 2005
12,248
1,319
Hi,

I'm having a bunch of issues getting my iMessages to sync across my iPhone 4s, iPad 2, and Macbook Pro.
AFAIK, iPads and Macs can only receive iMessages sent to email addresses.

So the trick is to get everyone to stop iMessaging your telephone number.

Like MikeCase mentioned, on your iPhone > Settings > Messages > Receive At > Caller ID, consider changing that from your telephone number to your email address.

This means that each iMessage you send from your phone will show as being sent from your email address (which, if your friends have that in your contact, they'll probably never notice it), but it also means that when people reply to it, it should go back to ALL of your devices.

But if you get a friend that initiates a new iMessage conversation straight to your telephone number, you're not going to see it on your iPad or Mac.
 

TheOnlyColors

macrumors newbie
Original poster
Mar 24, 2012
6
0
AFAIK, iPads and Macs can only receive iMessages sent to email addresses.

So the trick is to get everyone to stop iMessaging your telephone number.

Like MikeCase mentioned, on your iPhone > Settings > Messages > Receive At > Caller ID, consider changing that from your telephone number to your email address.

This means that each iMessage you send from your phone will show as being sent from your email address (which, if your friends have that in your contact, they'll probably never notice it), but it also means that when people reply to it, it should go back to ALL of your devices.

But if you get a friend that initiates a new iMessage conversation straight to your telephone number, you're not going to see it on your iPad or Mac.
That's what I was getting, but that doesn't explain why my new contacts are being sent to all my devices when they only have my phone number.

I'm wondering now if I exported all of my contacts, deleted them, and created them again if all my conversations would sync across all my devices.
 

aristobrat

macrumors G5
Oct 14, 2005
12,248
1,319
That's what I was getting, but that doesn't explain why my new contacts are being sent to all my devices when they only have my phone number.
Never heard of that happing before, so I'm not sure.

AFAIK, about the only thing you can do is set your iMessage Caller ID on your iPhone to be your email address. Then all of the new conversations you start (and replies to current conversations) will all appear to be from the same "source", and keeps duplicate threads to a minimum.