imessage thinks my friend has an iphone?

Discussion in 'iOS 5 and earlier' started by tiim.23, Mar 2, 2012.

  1. tiim.23 macrumors newbie

    Joined:
    Mar 2, 2012
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    hi guys! this is my first post so i'm sorry if I do anything wrong!

    basically my friend has a blackberry, but for some reason my phone has linked his number with iMessage... so when i text him he doesn't get them because he doesn't have an iPhone!

    has this happened to anyone else? does anyone have a fix?

    thanks for your time!

    Tim
     
  2. AlphaVictor87 macrumors 6502a

    AlphaVictor87

    Joined:
    Sep 7, 2011
    Location:
    Saint Louis, MO
    #2
    does he happen to have an apple id/itunes account?

    If he does and he uses his regular email as his account, and you have that in your contacts, that could be the problem.
     
  3. tiim.23 thread starter macrumors newbie

    Joined:
    Mar 2, 2012
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    i've thought about the email address before but in my contact list i only have his number, nothing else :/
     
  4. andyvp macrumors member

    Joined:
    Feb 1, 2008
    Location:
    Detroit, MI
    #5
    That's easy to fix, tell him to get an iPhone
     
  5. eric/ Guest

    eric/

    Joined:
    Sep 19, 2011
    Location:
    Ohio, United States
    #6
    hm, that's really weird. I think you can force it to send as a text message though.
     
  6. class77 macrumors 6502a

    class77

    Joined:
    Nov 16, 2010
    #7
    Type in the message and hit send. As soon as you do, hold the message on the display and hit "send as text". I've encountered this a few times
     
  7. macbook pro i5, Mar 2, 2012
    Last edited: Mar 3, 2012

    macbook pro i5 macrumors 65816

    macbook pro i5

    Joined:
    May 13, 2011
    Location:
    New Zealand
    #8

    :d
     
  8. tiim.23 thread starter macrumors newbie

    Joined:
    Mar 2, 2012
    #9
    works a treat! thank you :)
     
  9. Tenorsaw macrumors regular

    Joined:
    Jun 5, 2008
    #10
    If your friend has a GSM blackberry, temporarily put the sim card in an iPhone, go into settings and turn off iMessage.
     
  10. vebs macrumors regular

    Joined:
    Jun 24, 2010
    Location:
    Leicester, UK
    #11
    I'm not very impressed with the way Apple decided to implement iMessage, trying to simplify and streamline things goes too far sometimes.
     

Share This Page