iMessage to my ipad through my phone number

Discussion in 'iOS 6' started by tigress666, Sep 22, 2012.

  1. tigress666 macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #1
    How am I supposed to set this up so it works?

    So far it still doesn't work, my roommate has to text me on my me.com addee for it to go to all my devices. My phone number only sends to my phone number.

    Does he have to have iOS6 for this to work as well? Though I'm not seeing on my ipad that it is linked to the phone number at all (ipad is on iOS6 as well as my iphone. My Mac is still on Lion though <- and that is why I'm assuming it does not send or receive imessages properly anymore so I'm not worried about it yet).

    I added my phone after my iPad (when I got my new iPhone it had it and I kept my old iphone on iOS 5. My iPad I decided to try out iOS6 before my iphone came out). I just read that you have to activate the iphone first? So how do you fix it if you didn't? They can't possibly make it so it's impossible if you didn't do the right order the first time.
     
  2. lokiju macrumors 6502

    Joined:
    Jun 10, 2008
    #2
    Disable it on the iPhone and iPad. Then enable it on the iPhone and select both your email and phone number for the can be reached at options.

    Then enable on your iPad and it should detect your choices on the iPhone and pop up asking if you want to use the phone number also.
     
  3. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #3
    Do you mean like sign out on imessages from your apple id on your iphone and from imessages on the ipad (it won't let you remove the phone number) and then telling it to use your apple id on it then signing back in on the ipad?

    Because I do that, I then tell it to use my apple id as my id, sign in on the iphone. Then try signing in from the ipad and it does not get the reference.

    But whenever I do this I get a message ont he other device that it acknowledges the other device is using my apple id for imessage, it just won't make the connection between my id and my phone number.

    I do have two apple ids (an older one before icloud that i use to purchase my apps. I couldn't use it for icloud if I wanted to port my mobileme info over so I just made two apple ids. Since the one I'm using is associated with icloud I don't think that should matter. The other one is stricty associated with buying music and apps and not icloud at all).

    I've tried deleting the icloud account from the ipad and re signing in on the icloud account. No go.
     
  4. SunnyFL macrumors regular

    Joined:
    Jul 12, 2010
    #4
    I am guessing that both devices must be running IOS6 for this to work?
     
  5. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #5
    correct
     
  6. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #6
    Apparently sometimes that doesn't even work because I have iOS on both my iPad and my iPhone.
     
  7. Bebel macrumors member

    Joined:
    Jan 8, 2008
    #7
    I had to reboot my iPhone and then disable and then enable iMessage on my iPad for it to show up
     
  8. Goteman macrumors newbie

    Joined:
    Dec 18, 2007
    Location:
    Houston, Texas
    #8
    This solved it for me!

    Thanks man, this solved the problem for me too. I restarted my iPhone 4s, restarted the iPad (3rd gen) and then went to iMessage in settings, turned it off and then on again (first time it wouldn't "flip the switch" but the 2nd time it worked and after asking me to verify my Apple ID password all the sudden I saw the option of enabling my phone number and my .mac ID as well as my .me ID. Now all works.
     
  9. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #9
    Thanks, sadly that didn't work for me either.

    I got a genius appointment tomorrow but judging from my experience it won't help much.
     
  10. paulbee macrumors member

    Joined:
    Nov 17, 2011
    #10
    I was having problems with this as well, and rebooting the devices involved didn't work for me either. Then I found the problem, which I think was due to some wires getting crossed in the upgrade to iOS6. I use two Apple IDs -- one for my store purchase and a me.com address for iCloud. Back when iMessage made its debut in iOS5, I had set it up with the me.com account. But for some reason, when I checked, iMessage on my iPhone was set up to use my other Apple ID. I know this wasn't the case all along, as I'd been receiving iMessages through the me.com account, so I can only assume that for some reason the wrong account got attached to iMessage when I upgraded. Anyway, after I removed the incorrect Apple ID and added the me.com account to iMessage on the iPhone, I was able to sign back in on my iPad and Mac, and my phone number showed up on both the other devices immediately. I haven't tested to make sure they can receive messages yet, but it looks as if things are showing fine.

    Short version: Check on each of the devices you're using to make sure you have the correct Apple ID associated with all of them.
     
  11. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #11
    I do though one of them keeps trying to auto sign me up as the non me.com (that is not associated with icloud, just an apple id) addee and I keep having to correct it to the right email address. But I don't sign it up under the non me.com address but it does seem to think I should when I sign up. I wonder if that has something to do with it and how do I get it to not associate with that address?

    ----------

    Well, I don't know what I just did, but I fixed it... oh, I went into my apple id manager thing on the web and put my phone number in the mobile spot (it apparently was just in my main spot).

    That seemed to do the trick.
     
  12. somethingelsefl macrumors 6502

    somethingelsefl

    Joined:
    Dec 22, 2008
    Location:
    Tampa, FL
    #12
    THANK YOU SO MUCH. This solved my problem. You are a hero good sir
     

Share This Page