iMessage trouble

Patchy91

macrumors newbie
Original poster
Oct 3, 2012
1
0
Okay so my wife and I use the same iTunes account so both our phones are logged under the one username. Every time I try to send her a message with iMessage it just sends it to me. So now I have to turn off iMessage every time I text her. Any ideas on how to fix this?
 

diegoesk

macrumors regular
Dec 19, 2010
210
0
Try Creating your wife her own itunes profile.

If your using a mac- hold down option button before opening itunes.
 

hendooman

macrumors newbie
Sep 30, 2012
11
0
KC
^^^correct, you could still continue to share the same library, but two apple id's are a must to be able to message back and forth.

Although I was just thinking that on your phone you have an option to send and receive from multiple id's. SO I have my phone #, and my apple id username, that I can send and receive from. You could turn on send and receive from your #, and your wife turn on send and receive from the apple id. When you initiate the first text make sure to send to your apple id only. Test that and see if it works.
 

auero

macrumors 65816
Sep 15, 2006
1,366
96
You both need separate iCloud accounts for you and your wife.

Each of my family members has their own iCloud account.
user1@icloud.com
user2@icloud.com
user3@icloud.com etc...

Then go into General>iTunes & App Stores and sign out of the iCloud account on each phone. Then you can share the account you use to purchase apps, etc. (Which would probably be the account you are currently trying to share)

This gives us the ability to share our applications and music so we don't have to purchase duplicates of apps.
 

lemieuxfan67

macrumors member
Sep 26, 2012
70
16
Try Creating your wife her own itunes profile.

If your using a mac- hold down option button before opening itunes.
Creating a new itunes library is not necessary.

Just create her her own apple ID. Use this apple ID for her iMessage and Facetime. If you still want to share paid apps, continue to use your apple ID for the app store.
 

TSKY74

macrumors regular
Apr 14, 2012
118
0
Check the iMessage settings on the phones. Make sure her number is not selected on your phone and vice versa on her phone. I had the same issue and noticed that's phone had both my number and her number checked on my phone (as we're the two emails) that were associated to the one iTunes account. That fixed my duplication problems. Hope this helps
 

mattopotamus

macrumors G5
Jun 12, 2012
13,768
4,253
You both need separate iCloud accounts for you and your wife.

Each of my family members has their own iCloud account.
user1@icloud.com
user2@icloud.com
user3@icloud.com etc...

Then go into General>iTunes & App Stores and sign out of the iCloud account on each phone. Then you can share the account you use to purchase apps, etc. (Which would probably be the account you are currently trying to share)

This gives us the ability to share our applications and music so we don't have to purchase duplicates of apps.
this. Have separate Id's to use for everything accept the app store.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.