iMessage trying to send on 3G

Discussion in 'iOS 5 and earlier' started by mooseface, Jan 16, 2012.

  1. mooseface macrumors member

    Joined:
    Apr 28, 2009
    #1
    I seem to be having a problem with iMessage on my IP4. It will work as intended when I'm on wi-fi, but when I'm on 3G it will try to send as an iMessage, and not a standard text. As I understand it is meant to realise when it's on wi-fi or 3G and use either text or IM? I can get around it by waiting for the IM to fail and then force it to send as a text, but I usually forget this and don't realise it hasn't sent. Any ideas?
     
  2. Puonti macrumors 6502a

    Joined:
    Mar 14, 2011
    #2
    iMessage requires a data connection but doesn't really care wether it's WiFi or 3G (if WiFi is available the phone will prefer that, though). I'm not sure why your iMessages are failing over 3G - I'm assuming you have a 3G data plan, otherwise there's really no point in keeping 3G enabled.
     
  3. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #3
    I think the difference is whether the intended recipient has his/her iDevice active. If it's off, the message will go SMS style... at least that's what I've noticed.
     
  4. mooseface thread starter macrumors member

    Joined:
    Apr 28, 2009
    #4
    That's what I thought. I assumed that wi-fi=iMessage and 3G=SMS. It doesn't seem to crossover from wi-fi to 3G, I have to either manually turn wi-fi off, or wait for it to fail and resend as SMS.
     
  5. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #5
    Don't wait for it to fail. Press and hold the message and you can instantly choose 'send as text message'.
     

Share This Page