iMessage unread count stuck at 1

Discussion in 'OS X Yosemite (10.10)' started by yalag, Sep 4, 2014.

  1. yalag macrumors 65816

    Joined:
    Nov 18, 2007
    #1
    iMessage unread count stuck at 1. Anyway to fix this? I've tried signing in and out. Rebooting, restarting app etc.
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    Do you have an unread message in another folder somewhere?
     
  3. yalag thread starter macrumors 65816

    Joined:
    Nov 18, 2007
    #3
    Do you mean conversations? No every single conversation I've checked, it's read.
     
  4. j800r Suspended

    Joined:
    Jan 5, 2011
    Location:
    Coventry, West mids, England
    #4
    Unable to replicate in beta 2. Just file and sit tight. Bugs are to be expected after all. (yes, I know it's getting old me constantly saying the same thing but doesn't make it any less true :p)
     
  5. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #5
    What about logging into your email account from a web interface and checking for unread messages? Try that, and maybe even 'mark all as read' from there and then see if it clears the dock icon.
     
  6. yalag thread starter macrumors 65816

    Joined:
    Nov 18, 2007
    #6
    The problem is with iMessage, not email.

    ----------

    Is there a way to reset iMessage?
     
  7. The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #7
    Is there a web interface/Mark all as Read for iMessage?

    Related to OP: I had an unread iMessage that wouldn't go away, but it showed up the day before DP7 and went away after updating.

    How about disabling/enabling the account in iMessage prefs? Maybe even try deleting the account and then add it back in?
     
  8. yalag thread starter macrumors 65816

    Joined:
    Nov 18, 2007
    #8
    I can't delete the account for some reason. The minus button is greyed out when I go to iMessage's preferences and account.
     
  9. The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #9
    I don't have my DP7 MBA in front of me at the moment. Currently using my Mav iMac.

    I think you just highlight the iMessage account, then on the right under settings, uncheck the "Enable this account" checkbox. To remove it, I think you click "Sign Out" (based on what I'm seeing in Mavericks).
     
  10. yalag thread starter macrumors 65816

    Joined:
    Nov 18, 2007
    #10
    I tried both enable and sign out. It doesn't fix it.
     
  11. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #11
    Oh shoot! I'm sorry, I thought this was email we were talking about. My bad. :eek:

    No, there is no web interface to iMessage.
     
  12. The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #12
    All in jest! I forgot my ;)
     
  13. kmj2318 macrumors 68000

    kmj2318

    Joined:
    Aug 22, 2007
    Location:
    Naples, FL
    #13
    The same thing happened to me. I got an iMessage notification on my computer, and responded to it on my phone. Then the 1 badge was stuck on the messages icon and nothing got rid of it except restarting (but maybe killall Dock or just signing out would suffice).
     
  14. j800r Suspended

    Joined:
    Jan 5, 2011
    Location:
    Coventry, West mids, England
    #14
    Ah, well in that case it's probably iOS not playing nicely with the Yosemite beta and vice-versa. That'll probably be gone come release.
     
  15. TheGrandMoff macrumors newbie

    TheGrandMoff

    Joined:
    Jan 16, 2014
    Location:
    Utah
    #15
    I had the same problem as well. It is gone today. I think it was due to my iPad not playing well with the beta, as you said.
     

Share This Page