iMessage "Waiting for activation" bug ?

Discussion in 'iOS 8' started by killerbot, May 23, 2015.

  1. killerbot macrumors newbie

    Joined:
    May 23, 2015
    #1
    Hi,
    I have an iPhone6 running on iOS8.3. Everything's working fine :) but there's a bug with iMessage. When I want to enable it, it works :) But if I put the iPhone on Airplane mode, iMessage is in "Waiting for activation" state. Two solutions :
    - Reset network settings
    - Restart iPhone
    Do you also have this problem ?
    Thanks in advance ;)
     
  2. EdgardasB macrumors 6502a

    EdgardasB

    Joined:
    Apr 14, 2014
    Location:
    Lithuania
    #2
    iMessage needs internet connection and when you turn on airplane mode, your internet connection is turned off.
     
  3. killerbot thread starter macrumors newbie

    Joined:
    May 23, 2015
    #3
    I'm not stupid :p but the problem is even if I have an Internet connection after turning off airplane mode, it's still "Waiting for activation" :S
     
  4. iConnected macrumors 6502a

    iConnected

    Joined:
    Feb 17, 2011
    #4
    How about just disabling, waiting a short while, then re-enabling iMessage alone, via Settings?

    Does that clear it?

    ----------

    There's a longer process that might work here (disable each of iMessage and FaceTime, restart the phone, re-enable each):

    https://support.apple.com/en-gb/HT201422
     
  5. killerbot thread starter macrumors newbie

    Joined:
    May 23, 2015
    #5
    No I tried it but it doesn't work. I also disabled iMessage before turning on Airplane mode. Then I turned it off and re-enabled iMessage but no, still on "Waiting for activation".
     
  6. killerbot thread starter macrumors newbie

    Joined:
    May 23, 2015
    #6
    I just saw your link and yes it works again if I restart the phone like I said, but if I should do the same process each time I switch to Airplane mode
     
  7. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #7
    Sounds like you are turning it on and off. Why not just leave it activated ?
     
  8. killerbot thread starter macrumors newbie

    Joined:
    May 23, 2015
    #8
    - Are you talking about iMessage ? Of course I leave it activated. But when I switch on Airplane mode, iMessage is "Waiting for activation".

    - If you're talking about Airplane mode, I turn it on before going to bed.
     
  9. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #9
    I turned airplane mode on and off. No issue with imessage activation. Why not turn on do not disturb or mute the phone and see if it makes a difference?
     
  10. killerbot thread starter macrumors newbie

    Joined:
    May 23, 2015
    #10
    If I turn on "Do Not Disturb" iMessage is still ok :)
    Of course I turn on Airplane mode because of the waves :rolleyes:
     
  11. killerbot thread starter macrumors newbie

    Joined:
    May 23, 2015
    #11
    Strange ! It seems if I turn on Airplane mode (using Control Center) while on iMessage page in Settings, the iMessage still works :)
    But if I'm outside, turn on Airplane mode then go to iMessage settings, iMessage is "Waiting for activation" x)
     
  12. anupviews macrumors newbie

    Joined:
    Aug 31, 2013
  13. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #13
    Try signing out of iCloud, restart the phone, then sign back in. Worked for me when I had that problem.
     
  14. techhead1 macrumors newbie

    techhead1

    Joined:
    Nov 16, 2015

Share This Page