iMessage 'waiting for activation'

Discussion in 'iOS 5 and earlier' started by Zhanmei, Oct 13, 2011.

  1. Zhanmei macrumors newbie

    Oct 13, 2011
    Sorry to disturb. My problem is when I am trying to enable iMessage, it shows 'waiting for activation' for good. I don't know how to fix it.

    I have tried to restart the phone, pick-up the sim card. Nothing else happens.
    The network is stable.

    Please help. Thanks so much.
  2. Jedi5 macrumors 6502


    Aug 16, 2009
    North Burbs, IL
    many threads on this subject.
    trying turning the tab on/off... i think that was suggested by some.
    most likely that won't work but few did have success with that.
    if not, you'll just have to wait it out like others including myself did.
    it'll just activate on its own.

    also, while it might not be activated yet, it still might work.
    i know for me and others here, iMessage was working while it was showing us
    "waiting for activation"
  3. Zhanmei thread starter macrumors newbie

    Oct 13, 2011
    Thanks for your replay. I will keep waiting.
    I am just wondering why my iPad/iPod Touch can be activated in just seconds each time I try.

    The 3 iOS devices (iPhone, iPad, iPod Touch) all use the same Apple ID and WiFi. Why they act quite differently.
  4. egsedrop macrumors newbie

    Oct 22, 2011
    imessgae waiting for activation

    I had the same problem but solved it very easily by doing a restore of ios 5from itunes. Backed up iphone. then restored back up.
  5. trojantony1 macrumors newbie

    Oct 27, 2011
    hey guys,

    just thought id add my 2 cents for others that may go through this..

    i had the same problem after i did a hard reset yesterday. was working fine up until that point. the thing that worked to get iMessages and FaceTime working again was a backup and restore from iTunes. only took ten mins and now both are working flawlessly
  6. Jumphaly macrumors newbie

    Nov 14, 2012
    I have an Iphone 4s, even do my iMessage is working in the settings tab is still showing waiting for activation, i repeat is working but i just dont know why the message is stil there, can someone please help me fix this issue.

    Btw i have ios 6.0.1

Share This Page