iMessage, why do I only recieve them on my iPhone?

Discussion in 'iOS 5 and earlier' started by qwerty3089, Mar 29, 2012.

  1. qwerty3089 macrumors newbie

    Joined:
    Feb 10, 2012
    #1
    So I have both an iPhone 4 and iPad 3 (and an iPad2 before that), both running iOS 5.1. I've tried to figure this out in the past but had no real luck.

    I was under the impression that, with iMessage, you can not only avoid text message charges by using wifi to send messages but also recieve said 'iMessages' accross multiple devices. So, for example, if my iPhone is charging in another room, and happen to have my iPad on me, and another iPhone owner sends me a text message, I'd be able to get it on both my iPad and iPhone and reply to it via either device. iMessage is tuned on, on both devices BTW.


    A very large percentage of the people I know all have iPhones, so this feature would be really useful. Is this possible? If so, how do I set it up?

    If it's not possible, it should be. It would make communication a lot easier when people are away from their phones, but are near another idevice.

    Any help is appreciated.
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    If I understand it right, they have to have your Apple ID email in your contact info, and send it that way. If they are only sending to your phone number, then it will only go to the phone.
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    If the iMessage is being sent to your phone number, only your iPhone gets it. To send it to all devices, your iPhone and iPad must be using the same Apple ID and the the iMessage must be sent to your Apple ID.
     
  4. WordMasterRice macrumors 6502a

    Joined:
    Aug 3, 2010
    Location:
    Upstate NY
    #4
    I hate to be one of those guys, but there are like 9283748762384756234 threads on this exact subject. The answer is simply this, iMessage doesn't entirely work as it should but for the best results setup your iMessage caller id as your AppleID (Can be found in settings > messages > Receive At > Caller ID)

    Also have your friends send the messages to your AppleID rather than your phone number.
     
  5. Drunken Master macrumors 65816

    Drunken Master

    Joined:
    Jul 19, 2011
    #5
    Do you?
     
  6. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #6
    On your iPhone, to go to Settings > Messages > iMessage > ON

    Then, in same screen Receive at > Where it says "You can be reached for messages at: put your phone number AND your email address(-es)

    On your iPad, do the same thing but (of course) without your phone number.

    The first time you contact someone via iMessage using your iPhone, it may only show up on your iPhone and not the iPad. BUT, if you send an iMessage to the same person via your iPad, it will show up on both from then on.

    BTW - there's sometimes a delay in iPhone iMessages appearing on the iPad.
     
  7. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #7
    In addition, all of your iDevices should have the CallerID checkmark placed on your email address.
    That way you do not get multiple threads going to same person (depending if you are on iPad or iPhone)
     
  8. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast

Share This Page