Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors member
Original poster
Jul 11, 2008
I can't get this issue resolved and feel like I've been taking crazy pills.

The problem is, despite whatever I try, that I cannot get my phones (Verizon iPhone 6, 6s, and 5c all running latest OSes) to send pictures through iMessage while I am on my home's WiFi. iMessage texts work perfectly find AND I can send iMessage pictures over cellular service. To further complicate matters, other family members on AT&T iPhones have come over and used iMessage on my wifi and had no issues. My iMessage will also work on other family member's WiFi.

Here is my setup: Atlantic Broadband, Motorola Surfboard 6141, Apple Airport Extreme w/ Airport extender.And here is what I have tried to remedy the problem.

- Called Apple and per their direction I turned off/on iMessage, Sign Out/In of iMessage, turned messages off/on, reset network settings. Nothing worked. They finally had me do a restore and that did not work.

- I've tried a new router. Tp Link Archer C9. That did not work.

I'm at a loss and can't make any sense of the problem. Has anyone ran into this issue or have a possible solution? Thanks for any help!


macrumors newbie
Jul 12, 2016
Did this problem just start for you? We may be having the same issue... Everything was working just fine for me and then all the sudden within the last week this started happening. I'm equally frustrated and have had zero success in resolving the issue as well.


macrumors member
Original poster
Jul 11, 2008
Sense, Yes the problem just started happening. I'd say within the last two weeks or some. Other than a few iMessage outages, this if the firstl real problem I've had with the service. Are you on Verizon as well?

I7guy, I've tried numerous updates for carriers settings, nothing works. I called my ISP for a modem reset and that didn't work.

It's very frustrating.

If anyone has a fix or can find the fix I'll PayPal you $50.

now i see it

macrumors G4
Jan 2, 2002
Make sure that Messages is set up correctly.

Go to:
Settings/Messages/Send & Receive

Make sure that your email address and phone number is set up correctly:



macrumors 6502
Oct 6, 2012
I have the same issue....everything mentioned to look for in the previous post was OK when I went there, so no fix yet.

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.