iMessage with only WiFi (Verizon)

Discussion in 'iPhone' started by Sandman1969, Dec 29, 2013.

  1. Sandman1969 macrumors 6502a

    Sandman1969

    Joined:
    Nov 5, 2007
    #1
    Friend gave me his old iPhone 4 (Verizon) and I gave to my daughter to use as an iPod. I want to let her send iMessages to family with iPhones, but cannot seem to get it to work. I have my son setup with our old iPhone (AT&T) with SIM card removed and it works without a problem. However, since the Verizon doesn't have a removable SIM card I can't seem to get it to work.

    I can put it in Airplane mode and enable WIFI and can surf, use iTunes and other internet enabled apps. But whenever I try to send a Text Message it says you must disables airplane mode to send or receive messages.

    Is there anyway to force it to bypass the Cellular data and strictly use WiFi like my Son's AT&T iPhone. I have it set to use iMessage with her iCloud account and turned off SMS messaging. I also turned off Cellular data to restrict all data to WiFi.

    Thanks
     
  2. The Doctor11 macrumors 603

    The Doctor11

    Joined:
    Dec 15, 2013
    Location:
    New York
    #2
    I have poor wifi connection in my room so I put my phone in airplane mode all the time so it won't switch over to 3G. I can tell you form day by day experience if you hit cancel it will work just fine as long as your on wifi. Please tell me how it goes.
     

    Attached Files:

  3. uiop. macrumors 68020

    uiop.

    Joined:
    Jul 22, 2008
    Location:
    Grand Rapids, MI
    #3
    In that context, "messages" simply refers to non-iMessages. Which is correct, you obviously will not be able to receive SMS or MMS messages without cellular service. :)
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    yup, that's pretty much it.
     

Share This Page