iMessage with Phone Number on multiple devices - Possible Design Flaw

Discussion in 'iOS 6' started by timlopez, Sep 24, 2012.

  1. timlopez macrumors member

    Joined:
    Feb 12, 2009
    #1
    I searched the forums for another thread on this topic, and apologize if this is brought up somewhere else.

    I added my phone number to iMessage on my iPhone and have it configured on my Macbook and iPad as well. Works great at sending as the phone number and works great receiving as well.

    So, iMessage is having some trouble with activations, as discussed in a few other threads. This caused iMessage for some reason to become disabled on my phone. This sets up what I feel is a design flaw.

    I was hanging with a friend and showed up to his house but he wasn't there, so I text'd him (he has an iPhone as well) to find out where he was. No reply. Eventually I called him and we met up. During the day I text'd my wife and never heard back from her. Eventually I called her and she said she had text'd me back. I looked in the settings and realized iMessage was disabled (turned off).

    I knew that I would get home and those messages would be on my iPad. Low and behold, they were.

    Summary: If you add your phone number to iMessage but your phone is out of service (not yet verified, but assumed - tried with Airplane Mode on, send message, airplane mode off, and it never came through) or iMessage for some reason turns off, you will not get your text messages that are sent from other iPhones running 5.x and above.

    Anyone else have experience with this? As much as I love being able to send text messages as my phone number from the Macbook and iPad, I need to make sure people who text my phone get through to my phone.
     
  2. dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #2
    Ah I get it. So if my phone is out of range (I'm on a flight, for example), but my iPad at home receives the text, my phone never will?

    If so, yeah - that's a flaw. You would assume those iMessages would be queued up to be sent later to the iPhone when it is back in range.

    *wanders off to try and recreate this....
     
  3. matty.p macrumors 6502

    Joined:
    Jun 24, 2010
    Location:
    Portland, OR
    #3
    I don't know if that's right. My experience has been if a device is online. Once it comes back it syncs back all the iMessages that were sent to or from other devices. Sometimes the order of messages is a bit wonky but it works
     
  4. timlopez thread starter macrumors member

    Joined:
    Feb 12, 2009
    #4
    It was like that for me too, until my phone number was bound to my Apple ID for iMessages. Now they seem to be sent successfully to the devices online, but not queued up for phones. Incidentally, previously if you were going from iPhone to iPhone and the other party was offline, it would end up sending as a text. That also will not occur anymore.
     
  5. grizfan macrumors member

    grizfan

    Joined:
    Feb 10, 2012
    Location:
    Boise, ID
    #5
    I noticed the same problem. I added my mobile number to messages on my MBP. Recently, I stopped getting messages from my wife's iPhone on my iPhone, but they were showing up on my MBP. Thanks to this thread, I checked the status of iMessage on my phone, and it was disabled. Not sure what caused it, but once I re-enabled things, I started getting text message again. Strange...
     
  6. wpc macrumors regular

    Joined:
    Jun 23, 2009
    Location:
    Canada
    #6
    This has happened to me. Received a message on iMessage on my MacBook and it was never sent to my iPhone. I thought having iMessage on multiple devices was meant to sync everything between them.
     
  7. timlopez thread starter macrumors member

    Joined:
    Feb 12, 2009
    #7
    Glad to hear I'm not the only one who noticed this gap. Hopefully Apple addresses this with a slight design change. While I know the convenience is great - it can't have these types of reproductions that cause you to not get your text messages (SMS or iMessage) while out and about.
     
  8. ghsNick macrumors 68020

    ghsNick

    Joined:
    May 25, 2010
    #8
    How To Add Phone Number To iMessage App on iMac?

    So iMessage is synced between my iPad, iPhone, and for the most part my iMac. But on my iMac I con only sync it through my email. How do I add my Phone Number to it so it syncs across all devices flawlessly?
     
  9. timlopez thread starter macrumors member

    Joined:
    Feb 12, 2009
    #9
    That's off topic, but Disable iMessage and Enable it on your phone and make sure you have your Apple ID logged in.
     

Share This Page