iMessage won't activate, people receiving my texts as email address

Discussion in 'iOS 8' started by Aluminum213, Sep 20, 2014.

  1. Aluminum213 macrumors 68040

    Aluminum213

    Joined:
    Mar 16, 2012
    #1
    This happened as soon as I got my iPhone 6 plus, help please
     
  2. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
    #2
    Have you tried deactivating and then activating again under the messages section of settings?
     
  3. Aluminum213 thread starter macrumors 68040

    Aluminum213

    Joined:
    Mar 16, 2012
    #3
    I've done that, signed in and out, not sure what else to do
     
  4. Hart1583 macrumors regular

    Hart1583

    Joined:
    Jun 7, 2011
    Location:
    Peoria, IL
    #4
    Had this issue. Was on with Apple tech support.
    They couldn't figure it out

    What fixed it for me was deleting the iCloud backup of my old phone. I unchecked the email address options, took a nap, woke up and it was fixed. Was broke from 9am to 6pm
     
  5. xanadeath macrumors 6502

    xanadeath

    Joined:
    Jul 31, 2008
    Location:
    California
    #5
    iMessage is being such a bitch to me right now. My messages are sending from my email address from my computer and from my phone number from my phone. But, if I send messages from my phone shortly after sending them from my computer, they will come from my phone as from my email address. After unchecking all email addresses for send and receive in both mac messages and my iPhone, my girlfriend is now saying that my messages don't go to her computer. This kinda sucks.
     
  6. sodaftl macrumors member

    sodaftl

    Joined:
    Jan 27, 2008
    Location:
    Fort Lauderdale, FL
    #6
    Had that issue today: received the iPhone 6 at 11 AM CT today, and texting was using SMS (green color for my messages).

    I went to settings > Messages and turned off iMessage, then immediately back on and saw a message underneath the option that iMessage was being activated (that went on for a couple of hours).

    I was texting a friend (still in green) around 2:30 PM CT and suddenly, my last message was turned into blue (iMessage was back) and I could see iMessage in the text input field.

    Good luck to you...
     
  7. Soultosoul, Sep 20, 2014
    Last edited: Sep 20, 2014

    Soultosoul macrumors member

    Joined:
    Nov 4, 2011
    #7
    Same thing here, but only on my ipad (after update to ios8). iphone 6 has option for phone #. Appears they are aware of it. Guess I'll just have to wait til it gets sorted out.


    Edit: sorry, just checked and iphone6 is the same as ipad. Was sending/receiving from phone # because I turned imessage off
     
  8. ZebraDude macrumors 6502a

    ZebraDude

    Joined:
    Sep 7, 2014
    Location:
    Naperville, IL
    #8
    Go into settings/messages/Send & Receive and check the lower section and make sure that the proper message address label is checked!
     
  9. Aluminum213 thread starter macrumors 68040

    Aluminum213

    Joined:
    Mar 16, 2012
    #9
    iMessage suddenly just activated , didn't do anything
     
  10. jkskrap macrumors member

    Joined:
    Sep 15, 2014
    Location:
    Beautiful SW Florida
    #10
    Grumble. Tried all above and my messages are still wacky on my new 6+. Sends only SMS, closes on its own, and etc etc. iphone 5 and iPad are working fine.
     

Share This Page