iMessage won't link to my phone number

Discussion in 'OS X Yosemite (10.10)' started by Cscottrun, Aug 2, 2014.

  1. Cscottrun macrumors 6502

    Joined:
    Oct 8, 2011
    #1
    iMessage in Yosemite is not giving me the option to start new conversations from my cell phone number, instead, it simply lists the emails I have associated with iMessage as options. Anyone have a fix for this? I know this has been a problem for some before Yosemite. I'm not sure if this is a Yosemite problem or just a problem thats been persisting with iMessage since it came out.
     
  2. Cscottrun thread starter macrumors 6502

    Joined:
    Oct 8, 2011
    #2
    Can anyone provide any help with this? Still haven't found a fix. Wondering if this is a problem on my end or with the Beta.
     
  3. madsci954 macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #3
    I've run into this issue on live versions of OSX and iOS before. Try diabling/signing out of iMessage on all of your devices. Then re-enable on your iPhone and set it up how you want. Then move on to your Mac.
     
  4. Dj64Mk7 macrumors 6502a

    Joined:
    Sep 15, 2013
    #4
    I don't have a fix for this, but I am having the issue as well.
     
  5. Cscottrun thread starter macrumors 6502

    Joined:
    Oct 8, 2011
    #5
    I'll give this a shot and update. Thanks.
     
  6. Dj64Mk7 macrumors 6502a

    Joined:
    Sep 15, 2013
    #6
    Thanks. For me at least, it worked great with both iMessage and FaceTime.
     
  7. Cscottrun thread starter macrumors 6502

    Joined:
    Oct 8, 2011
  8. Dj64Mk7 macrumors 6502a

    Joined:
    Sep 15, 2013
    #8
    So signing out/in again didn't work for you? What devices are you using, with what software version(s)?
     
  9. Cscottrun thread starter macrumors 6502

    Joined:
    Oct 8, 2011
    #9
    Didn't work. iOS 8 on an iPhone 5 and Yosemite Public on Mid 2011 Mac Air.

    And I had no problems when I was using Mavericks.
     
  10. Dj64Mk7 macrumors 6502a

    Joined:
    Sep 15, 2013
    #10

    Attached Files:

  11. Cscottrun thread starter macrumors 6502

    Joined:
    Oct 8, 2011
    #11

    Attached Files:

  12. Dj64Mk7 macrumors 6502a

    Joined:
    Sep 15, 2013
    #12
    Okay great. I see that your phone number isn't showing up at all. Could you take a screen of the same iOS pane, found at Settings > Messages > Send & Receive, as well? Mine is attached, like before.
     

    Attached Files:

  13. boston04and07 macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #13
    Has anyone found a fix for this? I was having the same issue with FaceTime - the same iCloud account was logged in on my iPhone and iPad running iOS 8 and my Mac running the Yosemite public beta. My number was showing up in iMessages on all three, but only on my phone for FaceTime - my Mac and iPad only showed email addresses. I frequently receive FaceTime calls that are directed at my phone number so I wanted to fix this. Oddly enough my iPhone number was showing up in Facetime's preferences for continuity.
     
  14. joker00 macrumors member

    Joined:
    Apr 30, 2011
    #14
    this is how i solved it

    For me I had to go back to my phone.

    settings -> messages -> send&recieve, make sure your emails are there or login. or out and in.
     
  15. jkk5us macrumors newbie

    Joined:
    Sep 3, 2016
    #15
    1. In settings, go to Messages and turn it off iMessage
    2. In settings, go to FaceTime and turn it off
    3. In Settings go to iCloud and turn off Backup
    4. In Settings go to iCloud and turn off iCloud Drive
    5. In Settings go to iCloud and go to the bottom and sign out and select Keep on your iPhone
    6. In Settings go to Phone and enter your original phone number keeping the + and 1 at the beginning
    7. In Settings turn off WiFi and Bluetooth
    8. If you have other devices logged into your iCloud account, repeat the previous for each device.
    9. Reboot phone by holding power and home button at the same time until it shuts off, then power back on.
    10 Once phone is back on, verify in Settings Phone that your original number is still there, if not change it again.
    11 In Settings, sign back into iCloud
    12 In Settings, turn on iMessages in Messages back on and go to Send and Receive and make sure your old number is checked and the new temp number is not checked.
    13 In Settings, turn Facteime back on and go to Send and Receive and make sure your old number is checked and the new temp number is not checked.
    14. In Settings go to iCloud and make sure iCloud Drive and Backup and back on
    15 In Settings go to Cellular then Cellular Data Options and turn on Data Roaming
    16. Repeat steps 11 to 14 for any additional devices
     

Share This Page