iMessage won't read my phone number...help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sosinsurr, Dec 18, 2011.

  1. sosinsurr macrumors regular

    Joined:
    Dec 18, 2011
    #1
    Tried everything in the book, even paid a guy $20 bucks off craigslist who said he can fix it...nothing works!

    When you go into "receive at" in the iMessage settings, my phone number still shows up grey.

    Any idea how to get it to work??
     
  2. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #2
    Yeah, so is mine, it's greyed out because you can't change it, but that means it's been verified and working.

    You paid someone for that?
     
  3. Leonard1818 macrumors 68020

    Joined:
    Nov 15, 2011
    #3
    I've got some snake oil I could sell you. Rub some of that on it and it'll allow you to change/update it GUARANTEED
     
  4. MandiGee33 macrumors newbie

    Joined:
    Jan 26, 2013
    #4
    I am also having a problem where Send/ receive says "no addresses" and my phone number is checked and grey. I have logged out even reset my phone. iMessage still isn't working. Very frustrated!!!
     
  5. techishi macrumors member

    Joined:
    Jan 26, 2013
    Location:
    US
    #5
    This might sound silly, but have you made sure that your phone number is linked to your Apple ID?
     
  6. sugar iphone macrumors newbie

    Joined:
    Jul 7, 2013
    #6
    Well i guess i fixed it
    1)turn off imessage
    2) go to contacts and create your own contact with only your own number, no email
    3)go to settings-phone-my number, and type in your number without the +61
    4)go to settings-general-date and time. make sure the 'set automatically' is on
    5)go to settings-mail,contacts,calenders, then in my info, select your own contact.
    6)forget your wifi network and then join again
    7) turn on imessage.
    it should work. it worked for me. step 3-6 doesnt necessarily have to be in that order.
     

Share This Page