iMessage: Works on iPhone but Not on iPad

Discussion in 'iOS 5 and earlier' started by Rabbithutch, Oct 20, 2011.

  1. Rabbithutch macrumors newbie

    Oct 16, 2011
    Wife and I each have an iPad original and an iPhone4. I got iOS5 loaded on all 4 devices, but there is much to learn about features in the new OS. Specifically, we've both had trouble with iMessages. We finally got it working on both her devices last night - after trying so many different things that I have no idea what change or combination of changes made it work.

    I can receive and send iMessages on my iPhone but not my iPad. I have no idea why not. On the iPad I have iMessage turned ON in Settings and I can see a valid email address in the Receive At box (the iPhone shows my phone number in this field). Show Subject Field and Send Read Receipts are both OFF. Nothing else appears in Messages Settings.

    When I look a Message Settings on the iPhone, I see different information displayed. IMessage is ON; Send Read Receipts is OFF; Send as SMS in ON (this option doesn't appear on the iPad settings); Receive At shows my phone number (this option doesn't appear on the iPad settings); MMS Messaging and Group Messaging and Show Subject Field are all ON and Character Count is OFF (again most of these options don't appear on the iPad - only Show Subject Field).

    I can't find any instructions anywhere that tell me how to go about setting up the iPad for Messages. I've tried changing the Receive At email address but if I use a different one I get and error: iMessage Validation: Unable to verify email because it is already in use. There is no option to allow me to input my phone number (or none that I know how to find).

    First, should I be able to receive iMessages on both devices? If so, what do I have to change on the iPad to make it work like the iPhone? I'm guessing here, but it seems that the iPhone is using the AT&T network as carrier for the messages, but the iPad is trying to use the Internet as carrier. Can the iPad use AT&T as carrier? Why would I ever want to use the Internet instead of AT&T?

    So many questions. So little information.
  2. dotme macrumors 6502a

    Oct 18, 2011
    Our setup as far as devices is like yours. Your phone has a phone number, your ipad does not. Therefore. iMessages sent to your phone number will never be received by your iPad.

    But on your iPad, messages are received by sending to your Apple ID, or any other email address you care to add. You can add those also to your iPhone, so messages sent to your Apple ID (not phone number) will then appear on both devices. It is a bit confusing, but play with things a bit and you'll get the idea.
  3. Rabbithutch, Oct 20, 2011
    Last edited: Oct 20, 2011

    Rabbithutch thread starter macrumors newbie

    Oct 16, 2011
    Thanks for the response. I kinda figured that the iPad was without cell network capability and would not get messages sent to the iPhone. What really puzzles me is that I have a message history on the iPad. I was receiving messages from my daughter on 14 Oct but not any longer. I just tried to send a test message from my iPhone to the iPad using the email address but the message was never received despite the iPad being on. The iPhone displays the test text as it would any message except it's in a blue colored bubble. There is not error message or any indicator that the message was not sent.

    Any ideas?

    Follow Up after More Fiddling Around:
    I tried to sent a message from the iPad to my daughter to ask if she received it on both her devices. As soon as I opened the message entry function, I received the message I sent from my iphone to the ipad. I was then able to send a message to her but have received no response yet. She has and iPhone4 and and iPad2 whereas mine is an original iPad.
  4. sooner518 macrumors member

    Oct 5, 2011
    on your phone, go to "Settings>messages>Receive At" and make sure you enter the same email address underneath your phone number. THEN, after it has been verified, on the same screen, hit Caller ID at the bottom.

    on the CallerID screen, It should ask you if you want to choose your phone number, or your email address. Choose the email address.

    Now, you should receive other iMessages (not SMS texts, but iMessages. so only people with iOS5) on both devices.

    HOWEVER! if people still are sending you messages from their phones, and they hit "New MEssage" and then start typing your name, chances are they will select your phone number because it shows up at the top and thats what theyve always done. It will still send as an iMEssage, but you will ONLY receive it on your phone in this case. you either have to tell them, or hope that they simply respond to your messages.

    IMO, Apple kinda screwed the pooch with integrating this whole iMessage thing into the iPad. they should have made a way to associate your iPad messaging account to a phone number. I am getting messages that appear on my iphone only, and some that show up on both my ipad and iphone. my friends have 2 different threads of messages for me on their phones. its kind of a mess right now.
  5. xraydoc macrumors demi-god


    Oct 9, 2005
    Correct. If someone sends an iMessage to your cellphone number it'll still only go to your iPhone. If they send it to your iCloud ID, it'll go to all your configured iOS 5 devices (iPhone, iPad, iPod).

    Make sure to set the "Caller ID" for your outgoing messages to your iCloud ID instead of your phone number.

    Your friends will need to make sure they have your iCloud ID in their contacts and they send messages to that ID (not your cellphone),
  6. star-affinity macrumors 6502a


    Nov 14, 2007
    Associate the mobile number with the Apple ID and vice versa

    Wouldn't it be easier the mobile number for ones iPhone and the Apple ID one has could be associated with each other, so when someone sends an iMessage to me it doesn't matter if that person choose to send to my iPhone number or my Apple ID email address. This would make the message arrive to all iOS devices (including Mac OS X now with without having to fiddle som much with settings.

Share This Page