iMessage-works on iPhone, doesn't mirror on iPad

Discussion in 'iOS 5 and earlier' started by mknoebel, Oct 29, 2011.

  1. mknoebel macrumors member

    Joined:
    Jan 16, 2011
    Location:
    CO
    #1
    I thought one of the features of iMessage was that I could have a conversation on my iPhone, then continue it on my iPad. Or vice/versa.

    I can send an iMessage from my iPad, and then I can also get a response on my iPad. But if I start on my iPhone, the iPad doesn't show any of it.

    I have checked my settings. When I look at "Receive At..." the Apple ID is the same on both, the iPhone has 4 addresses, the iPad has 3 addresses. The only difference is that the iPhone has my phone number plus the 3 email addresses.

    Any other settings I'm missing or did I misunderstand that you could pick up on a different device in the middle of messaging?
     
  2. ct2k7 macrumors 603

    ct2k7

    Joined:
    Aug 29, 2008
    Location:
    London or Florida
    #2
    Apparently, messages are not synced across devices. Would have worked better with iCloud IMO.
     
  3. dilutedq macrumors regular

    Joined:
    Jun 22, 2010
    #3
    They are definitely synced across devices. I'm assuming they need to be on the same itunes account. Both my iMessage chats mirror eachother instantly. So much so that when I read a message on one, it is no longer on the notification screen of the other.
     
  4. mknoebel thread starter macrumors member

    Joined:
    Jan 16, 2011
    Location:
    CO
    #4
    That's what I was anticipating/hoping for.
    As I mentioned above, I am signed in under the same Apple ID. So that's not it.
     
  5. andylyon macrumors 6502a

    andylyon

    Joined:
    Jul 23, 2008
    Location:
    London
    #5
    I think to get it to sync across devices you must choose to receive iMessages at ONLY your email address on your iPhone by removing your phone number from the iMessages settings pane.

    As far as I know an iPad cannot sync messages sent a phone number.
     
  6. mknoebel thread starter macrumors member

    Joined:
    Jan 16, 2011
    Location:
    CO
    #6
    And just to add to my setup... I just took a picture of my girls carving their pumpkins. It immediately showed up on my iPad in the photo stream tab. So I know the two are "talking" to each other!
     
  7. X5-452 macrumors 6502

    X5-452

    Joined:
    Feb 16, 2006
    Location:
    Calgary, Canada
    #7
    I'm having the same issue and it's somewhat frustrating. I was hoping to keep texting from my iPad while my iPhone charges. There has to be a way because I've seen other people do it...
     
  8. mknoebel thread starter macrumors member

    Joined:
    Jan 16, 2011
    Location:
    CO
    #8
    That's not even an option Andy. In the "Receive At" tab, the phone number is greyed out so that it can't be changed, deleted, etc.
     
  9. Summersify macrumors member

    Joined:
    Oct 29, 2011
    Location:
    UK
    #9
    It's not working for me either. It's disappointing.

    A friend of mine has an iPod Touch and an iPad and he claims that iMessage does sync between those two. There's no difference in setup between his and mine...
     
  10. josielinnea macrumors regular

    josielinnea

    Joined:
    Dec 15, 2007
    Location:
    Stockholm
    #10
    I have my iPhone and my iPad working this way, the messages come through on both devices even if they are sent to my phone number.
    This is what I did:
    Go to Settings -> Messages -> Log out of your Apple-ID and then back in again. Now click "Receive at: yourappleid@whatever.com" and then click the first part which doesn't look like a button but is "Apple-ID: yourappleid@whatever.com" -> Change location -> select your current country (mine isn't USA) -> hit Save.
    I then have to send the iMessage to a phone number that DOESN'T include my country code in the phone book, or enter the phone number manually without country code.

    I think somewhere in iOS it adds a double country code otherwise...
     
  11. mrtune macrumors 6502a

    Joined:
    Jun 23, 2007
    #11
    Change the caller ID in the messages settings area to your email address. By default it's set at your number. That way when you send an iMessage, the user on the other end will respond to your email address instead of your phone number.

    If someone sends you an iMessage via your phone number, only your iPhone will get it. If someone sends you an iMessage via your email address, both your iPhone and iPad will get it.

    I have no issues with keeping my iPad and iPhone messages in sync. The email address is the key, since there is no phone number for the iPad.

    Hope this helps.
     
  12. mox358 macrumors 6502

    mox358

    Joined:
    May 22, 2002
    Location:
    Indiana
    #12
    I was having this same problem and you solved it! Thanks, didn't know about the Caller ID thing. Good explanation too.
     
  13. mknoebel thread starter macrumors member

    Joined:
    Jan 16, 2011
    Location:
    CO
    #13
    This iMessage is fickle! I actually changed my caller ID to my email address about a week ago, but messages still weren't coming through on my iPad.

    After reading the suggestions here, I tried signing out of my Apple ID then re-signing in and again setting my Caller ID's to my email. They still weren't coming through on my iPad, but I replied on my iPad. After I did that it started showing up on both my iPhone and iPad!

    One weird thing though. When my wife gets my message now, it doesn't show up with my name like it did before, it shows up as the first part of my email address that I used for caller ID. Anyone know of a way for me to change how I'm seen? So that it can be my name instead of part of my email addy?
     
  14. robjulo macrumors 6502a

    Joined:
    Jul 16, 2010
    #14
    There is only limited syncing. If your IPad is off (or not connected) and you answered the iMessage on your phone, that message you responded to will not show up on your IPad.
     
  15. mknoebel thread starter macrumors member

    Joined:
    Jan 16, 2011
    Location:
    CO
    #15
    Nah, I had it on, iMessage open, and sitting on my lap watching nothing happen!! ;)
     
  16. OriolesMagic macrumors member

    Joined:
    Jun 10, 2009
    #16
    Just have her add your email address to her contacts.
     
  17. mrtune macrumors 6502a

    Joined:
    Jun 23, 2007
    #17
    The caller ID works for new conversations only I believe. If you have a previous conversation going with someone, they will keep responding to the original setting (your phone number). That's why when you send through your iPad it starts to work correctly. It will start a new conversation on the receiving end, with your email address instead of your number. Basically they will have 2 conversations in their messages app. One that goes to your number and the new one that goes to your email address.

    As for your wife. She needs to add your email address (that you're using for iMessages) into your contact information.
     
  18. mknoebel thread starter macrumors member

    Joined:
    Jan 16, 2011
    Location:
    CO
    #18
    She already had my email in her contacts, but she also had some linked accounts added to it - one of which was labeled with just my email address. When I deleted the linked account, I showed up with my name in her iMessage again. Weird, but I think it's working now.

    Thanks for all the help.
     
  19. shortcrust macrumors 6502

    Joined:
    Aug 7, 2008

Share This Page