iMessage

Discussion in 'Buying Tips and Advice' started by kjmff5, Apr 2, 2012.

  1. kjmff5 macrumors regular

    Joined:
    Mar 27, 2011
    #1
    So this is weird. I added my phone number and email address to the iMessage part in the settings of my iPhone, but when people try and text to my email, it still gets sent as MMS, but when people text my phone number it goes as iMessage. Any thoughts on how to fix this?
    Obviously people texting me are using iPhones, so thats not the issue(iOS 5). I can text other peoples' email address and that gets sent as iMessage to them.
     
  2. njean777 macrumors 6502

    Joined:
    Oct 17, 2009
    #2
    Imessage stopped working for completely a week after using it, I would just wait until it is officially released.
     
  3. yukio macrumors regular

    Joined:
    Feb 8, 2008
    #3
    what service is the email address on that you listed in iMessage?

    and - if you go to iMessage-->Preferences-->Accounts are all of the addresses that you want to have accessible to iMessage listed in the "You can be reached for messages at" section?

    check your iPhone's Messages settings and your Mac's iMessage settings and make sure that you are logging in with the same AppleID on both.
     
  4. kjmff5 thread starter macrumors regular

    Joined:
    Mar 27, 2011
    #4
    What do you mean what service? Gmail?
    And all there right emails and phone numbers are in the "reach at this number"
    And whats the Mac gotta do with this? I didn't install Messages Beta.
     
  5. yukio macrumors regular

    Joined:
    Feb 8, 2008
    #5
    you're right - i treated your issue as if it was mine.

    the trick that solved my issue was logging off of Messages on my phone (well, and all of my other gear too, which doesn't apply to you), shutting it off, turning it back on and then logging on again.

    then, my routing went back to normal.
     

Share This Page