iMessages and iPad2 sync issues

Discussion in 'iOS 5 and earlier' started by rayjay86, Oct 15, 2011.

  1. rayjay86 macrumors 6502

    Joined:
    May 15, 2011
    #1
    Hey guys; I posted this in response to another iMessages issue but I think me and the OP were having different problems so I made my own post.

    In the picture (which I've blurred for privacy) you can see that there are two messages showing up. The top message is from my iPhone and the bottom one is from my iPad2. The thing is, the recipient (my brother) has both my gmail account which is my Apple ID and my phone number attached to the same contact card.

    So problem 1 is that my iPad is sending separate messages.

    Problem 2 is that with friends who don't have my email address in their phone books, my iPad sends them a message from my email. My email has my full name in it so it's pretty easy to ID me when they get it, but the point is they are getting separate messages from the same contact.

    Problem 3 - My iPad and Phone aren't fully syncing the messages. For example when I start a message on my iPad, the messages sync to my phone, but any iMessages that were NOT sent from my iPad (but were sent through iMessages) are not showing up on the iPad completely...I'm not really sure why.
     

    Attached Files:

  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    No.

    The whole "problem" is what you choose as your "Caller ID" on YOUR phone. Go into settings > iMessage and choose your email address as your caller id for iMessages. Then your iPad and iPhone will have the same conversations.
     
  3. rayjay86 thread starter macrumors 6502

    Joined:
    May 15, 2011
    #3
    Yeah I get that but the discrepancy lies in the fact that a message I start on my iPhone was completely transferred over to my iPad with a different friend. But ten when I sent it from my iPad to him again it came up as a separate email...but the whole convo that I had started from my iPhone 15 min earlier was downloaded to the iPad.
     

Share This Page