Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Bugeyeblue

macrumors 6502a
Original poster
Mar 27, 2011
514
9
Ever since I installed ios 7 on my Verizon iphone 5, when an iMessage doesn't go through, it just keeps trying to send as an iMessage instead of converting to a text message after a minute or two. I have to go back to all my messages and make sure they've been sent, or long press on which ever one hasn't been sent, and select the "send as text" option. And yes, I have the option checked already for iMessages to deliver as text messages as needed in settings.
 

Fontane

macrumors regular
Feb 3, 2011
173
4
Ever since I installed ios 7 on my Verizon iphone 5, when an iMessage doesn't go through, it just keeps trying to send as an iMessage instead of converting to a text message after a minute or two. I have to go back to all my messages and make sure they've been sent, or long press on which ever one hasn't been sent, and select the "send as text" option. And yes, I have the option checked already for iMessages to deliver as text messages as needed in settings.

Not sure why your imessage is not sending as texts, but somewhat related to your issue, I had a problem with imessage not sending my messages at all. I went into Settings>General and reset the network settings. That fixed it.

Maybe your imessage is having the same issue as mine? Try resetting network settings.
 

Steviejobz

macrumors 68020
Jun 19, 2010
2,107
343
SoCal
Actually happy that it doesn't use text as default. Used to seem so arbitrary when it would do that. Rather I be given the option.
 

Kelcoshows

macrumors newbie
Feb 8, 2011
10
0
Hertfordshire UK
Ever since I installed ios 7 on my Verizon iphone 5, when an iMessage doesn't go through, it just keeps trying to send as an iMessage instead of converting to a text message after a minute or two. I have to go back to all my messages and make sure they've been sent, or long press on which ever one hasn't been sent, and select the "send as text" option. And yes, I have the option checked already for iMessages to deliver as text messages as needed in settings.


Are any of your messages successfully going as iMessages? Noticed today that I had iMessages 'stuck' since Saturday. After testing, found that all my iMessages were getting stuck like this. Turned phone off and on and all ok after.
 

davidra

macrumors 6502
Oct 12, 2011
413
4
Same here. iMessages to one person in particular who is on Sprint (I'm on Verizon) are not going through intermittently but when I reboot the phone they go through. Could this be a Verizon network issue?
 

rotlex

macrumors 6502a
May 1, 2003
673
406
PA
Jumping in here to follow. I'm seeing the same issue, ATT phone. iMessage keeps doing it to. I'll go to send a message, think it went etc., then look later in it is stuck in "sending". The only way to get things back appears to be a reboot of the phone. Happened more than once now.
 

Bugeyeblue

macrumors 6502a
Original poster
Mar 27, 2011
514
9
I'll post back again after I try using iMessage again today. Seems to be still having the same problem this morning unless I turn off my phone and turn it back on again.

----------

Actually happy that it doesn't use text as default. Used to seem so arbitrary when it would do that. Rather I be given the option.

Me too, but if it never says anything, you get no notification, and it just keeps "sending", it's going to kill the battery and you (or I) won't know why.

----------

Not sure why your imessage is not sending as texts, but somewhat related to your issue, I had a problem with imessage not sending my messages at all. I went into Settings>General and reset the network settings. That fixed it.

Maybe your imessage is having the same issue as mine? Try resetting network settings.

I'll give that a try. Thanks.
 

CorbinDallas

macrumors member
Sep 7, 2011
44
0
PA
By default, sending as SMS is not selected in IOS 7. To enable this go into settings>messages>send as SMS. This will send messages as regular SMS messages when imessage isn't available.
 

palmerc2

macrumors 68000
Feb 29, 2008
1,621
683
Los Angeles
By default, sending as SMS is not selected in IOS 7. To enable this go into settings>messages>send as SMS. This will send messages as regular SMS messages when imessage isn't available.

This.

This is how I had it set in iOS 6, but in iOS 7 reverted to not send as SMS when iMessage isn't available.
 

Bugeyeblue

macrumors 6502a
Original poster
Mar 27, 2011
514
9
By default, sending as SMS is not selected in IOS 7. To enable this go into settings>messages>send as SMS. This will send messages as regular SMS messages when imessage isn't available.

I posted in my originally post that I already had it set up that way. Thanks for the input though. I'm sure it'll help someone reading this.
 

ttinc

macrumors regular
Sep 12, 2013
126
0
I turned that feature off and told my friend in Brazil to turn it off as well after a slew of iMessages turned into texts that ended up charging both of us.
 

AppleCore77

macrumors member
Oct 10, 2012
51
0
I've been having problems with iMessages all weekend. And like others, even with the setting set as "send as SMS" it doesn't send it that way unless I hold the individual message and tap "send as text".
 

aDRock1154

macrumors 65816
Nov 15, 2011
1,388
5
Ohio
I've noticed the same problem, too. I have it set to send as a text if iMessage is unavailable. I also noticed that it takes forever to send as a text and I can hear the "sent" sound with my screen off like a minute or two later.
 

dmrowley

macrumors 6502
Aug 4, 2010
439
173
Dortches, NC
Using Verizon in NC here. Started having issues yesterday, turned off my iPhone 5 and turned on again, then had to tell Messages to try again. I t never fell back to SMS even though I had the option turned on. I just did the reset network thing, so we'll see if it helps. Fingers crossed.
 

Bugeyeblue

macrumors 6502a
Original poster
Mar 27, 2011
514
9
Using Verizon in NC here. Started having issues yesterday, turned off my iPhone 5 and turned on again, then had to tell Messages to try again. I t never fell back to SMS even though I had the option turned on. I just did the reset network thing, so we'll see if it helps. Fingers crossed.

I did the network reset and it helped for about a day. Started to be unreliable again today. Turned the phone off and on and it works. I don't know what's causing it to stop working and then start again.
 

dmrowley

macrumors 6502
Aug 4, 2010
439
173
Dortches, NC
I did the network reset and it helped for about a day. Started to be unreliable again today. Turned the phone off and on and it works. I don't know what's causing it to stop working and then start again.

Yep, me too. Had to turn it off and back on again today. Feels like an episode of The IT Crowd..
 

Bugeyeblue

macrumors 6502a
Original poster
Mar 27, 2011
514
9
Yep, me too. Had to turn it off and back on again today. Feels like an episode of The IT Crowd..

My next idea is to restart the phone once a day whenever I put it on the charger, probably in the morning.
 

Nebulance

macrumors 6502
Mar 11, 2010
401
128
I did the network reset and it helped for about a day. Started to be unreliable again today. Turned the phone off and on and it works. I don't know what's causing it to stop working and then start again.

I haven't tried the network settings reset, but restarting the phone yields the same result -- works for about a day, then I'll have to do it again.
 

Max(IT)

Suspended
Dec 8, 2009
8,551
1,662
Italy
This is clearly a problem of iOS 7 and it's not operator related ...

Sometimes I need to restart my iPhone (and my iPad also) to have iMessage works again.
Reset network settings works just for a couple days so I think it's not different than a reboot ...

I hope they'll fix this problem in a shot time, btw be sure to give apple a feedback on this via their site.
 

srharris22

macrumors member
Aug 28, 2010
94
58
Now I am not receiving texts, iMessages

So I've struggled with this for over a week now. Was happy to see Apple announce they are aware if the issue on Tuesday. I have found all options such as turn phone off /on and reset network will work for maybe a day. But starting 2 days I go I realized I was now not receiving texts/iMessages. My wife had been texting but I never got them and I had an iMessage on my iMac that never came through.
I have tried to turn off iMessage but still not receiving texts.
I have since decided to go under iMessage and opt to just use my email
Address when sending iMessages and it seems to be working - vs using my cell number.
 

enuenu

macrumors newbie
Jun 8, 2011
11
0
Necrobump warning, here we are in late 2015 and I am having exactly the same problem (iOS 9.1). I have "iMessage" and "Send as SMS" selected in message settings. The phone is my child's so data is disabled in settings.

When at home in WiFi range, iMessages send OK (IF greyed text "iMessage" is in message field). Then you walk up the street out of WiFi range and try to send a SMS. The phone keeps trying to send as an iMessage. I check settings for WiFi and it shows "Not connected". So the phone should immediately know it cannot send an iMessage. However it will not abandon its attempt to send as iMessage and revert to "Send as SMS" without the manual "long press" and then selecting "Send as SMS"

So I use the long press method to force it to send as SMS. Then the greyed text in message field now is "Text message". I walk back to the house and now I can't send an iMessage. It is stuck in "Text message" mode, despite the fact it is now connected to WiFi again. The opposite problem to the one I had 10 minutes earlier. This is all very frustrating.

The phone seems to get stuck trying to send a message the same way it sent the previous message, regardless of what message settings have been selected and whether the phone has Internet access or not.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.