iMessages not consistant across all devices

Discussion in 'iOS 6' started by elektrizitat, Sep 28, 2012.

  1. elektrizitat macrumors member

    Joined:
    Sep 22, 2009
    Location:
    London
    #1
    Hi there,

    Is anyone else experiencing this? I've got iOS6 with iMac, iPad and iPhone, and for some reason messages sent to me aren't syncing across all devices. iMessages only go to my iMac and iPad. I've changed the settings to disable my email address and use only my phone number, hoping that would rectify the problem as I put priority on my iPhone as I've always got it with me. I keep missing messages from people because they're not going to all devices, so I've turned it off on all for the time being.

    Has anyone else had this? Found a solution at all?
     
  2. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #2
    Have you tried turning Messages off/on on your iPhone? Settings>Messages>iMessage

    Edit: You might try that on all 3 devices.
     
  3. humar macrumors 6502

    humar

    Joined:
    Feb 17, 2012
    Location:
    Italy
    #3
    This is happening with my MacBook and my iPhone 4S... :mad:
     
  4. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #4
    Just to be sure...have you updated your MacBook to Mountain Lion 10.8.2? I made this mistake - didn't realize 10.8.2 was required.

    If so, you might try:
    On iPhone, Settings>Messages>iMessage toggle off/on

    On MacBook, Messages>Preferences>Accounts>>Apple ID: Sign Out, Sign In

    Good luck!
     
  5. humar macrumors 6502

    humar

    Joined:
    Feb 17, 2012
    Location:
    Italy
    #5
    Yes, I updated my MacBook to 10.8.2.. and I also added my telephone number in iMessage on my MB.. not always Mac and iPhone are synchronized..
    I'm trying to understand why..
     
  6. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
  7. JerseyDoug macrumors regular

    Joined:
    May 10, 2012
    #7
    Did you try this, yet?
     
  8. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #8
    And this: On MacBook, Messages>Preferences>Accounts>>Apple ID: Sign Out, Sign In

    One other point; only messages from/to other iMessage users will sync on all devices. SMS messages to others will not sync.
     
  9. maricc macrumors regular

    Joined:
    Oct 13, 2011
    #9
    My imessages never really worked with iOS 5, but actually seems to work better with 6.
     
  10. CB1234 macrumors 6502a

    CB1234

    Joined:
    Sep 20, 2012
    Location:
    Dubai, UAE
    #10
    Sorry for the dumb question - but how do you add phone number to iMessages on MBP???? When I go into preferences - accounts it only allows me to add email addresses and not phone number.

    Thanks for your help.
     
  11. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #11
    CB1234,

    Make sure your MBP has been updated to Mountain Lion 10.8.2, and your iPhone has been updated to iOS 6. I don't mean to offend, but I initially tried to sync my messages before I updated ML on my MBP, and of course, it didn't work.

    My next suggestion is that you confirm that your mobile phone number appears in your Apple ID account. You can access your account here.
    Others have said that this isn't necessary, but I'm not sure about that. Better safe than sorry.

    Next, follow these steps:

    On your MBP, open Messages>Preferences>Accounts
    You will see a box labeled "You can be reached for messages at"
    Your phone number should appear in the list - make sure the box is checked.

    If your phone number does not appear, try these steps:

    On iPhone, Settings>Messages>iMessage toggle off/on

    On MacBook, Messages>Preferences>Accounts>>Apple ID: Sign Out, Sign In

    Good luck!
     
  12. CB1234 macrumors 6502a

    CB1234

    Joined:
    Sep 20, 2012
    Location:
    Dubai, UAE
    #12

    I tried all that you said - but it doesn't work.

    I went to Appleid website and made sure all the phone numbers (Day, mobile and Evening) were my mobile number.

    When I sign off/on on my MBP it doesn't recognise my mobile number !!!

    On my iPhone it recognises my mobile number for iMessages, but refuses to let me add Apple ID to it.

    On my iPad 2 it won't let me add anything full stop. Not my mobile number nor my apple id…

    I read somewhere that on my MBP i could add my mobile number as an email address and then it should work. I tried that and it still doesn't work.

    I live in Dubai, UAE - where FaceTime is banned…. I wonder if this is anything to do with my iMessages not working on all my apple devices.

    But I am clutching at straws here, because before the upgrade iOS6 and ML came out, my iMessages Beta was working well across all my devices.

    I have done restore across all my iOS devices, but iMessage refuses to play ball.

    I get iMessages on iPhone with my number, and I can get messages on MBP with my apple id, but nothing on my iPad. And it is not synchronised across all my devices.

    This is driving me insane to the point, that I have resigned to the fact I will just have to wait for next upgrade from Apple and hopefully it will sort itself out.

    Thanks for trying to help me...
     
  13. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #13
    I'm sorry for the trouble you're having.

    Two more suggestions (just in case):

    Has your iPad been updated to iOS 6?
    On your iPad, is Messages turned on? Settings>Messages>iMessage "ON"

    I don't have any experience with any services that might be banned, nor do I know if FaceBook and Messages may be connected in some way. Can you contact Apple Support for help?
     
  14. CB1234 macrumors 6502a

    CB1234

    Joined:
    Sep 20, 2012
    Location:
    Dubai, UAE
    #14

    Yes the iPad was updated to iOS6….

    When I try to turn on iMessages it asks for Apple ID, which I try to enter and it keeps on giving me error message "user id or password incorrect".

    I have emailed Apple Support and hope to get a reply from them….

    Thanks again..
     
  15. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #15
    You are welcome. I'm sorry I couldn't be of more help. I'd be interested to see what Apple says, if you don't mind posting the result. Hopefully they'll get it working for you.
     
  16. CB1234 macrumors 6502a

    CB1234

    Joined:
    Sep 20, 2012
    Location:
    Dubai, UAE
    #16
    If i get a reply and it solves the problem - I will definitely post it…

    It may help other people who are having same problem as me…

    In all these year I have owned Apple products, I must admit this is the only time I am really annoyed with them…. But I am a die hard Apple fan, and I will just wait for the next amazing product they launch…
     
  17. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #17
    CB1234,

    I read this in another post:

    On your iPad, instead of just switching iMessage "Off," try signing out of your Apple ID account:
    Settings>Messages>Send & Receive>Tap on Apple ID:>Sign Out
    Sign in again

    If you haven't already done it, it might be worth a try. Others have said it solved the issue for them.
     
  18. mytran80 macrumors regular

    Joined:
    Mar 30, 2009
    #18
    i turn on my iMessage on my i5 after reboot and still doesn't work , what's up apple !!:mad::mad:
     
  19. CB1234 macrumors 6502a

    CB1234

    Joined:
    Sep 20, 2012
    Location:
    Dubai, UAE
    #19

    It doesn't allow me to sign on with my Apple ID in the first place, so no question of signing out.......
     
  20. CB1234 macrumors 6502a

    CB1234

    Joined:
    Sep 20, 2012
    Location:
    Dubai, UAE
    #20
    Just an update on my predicament syncing iMessage across all the devices.

    I still didn't get a reply from Apple, so I sorted myself out in a different way….

    What I did instead was create a UK APPLE ID and used that across all my devices. VIOLA !!! my iMessage is now working and synced right across my IP 4S, iPad 2 and MBP…

    I do not know if our local telecommunication provider in Dubai, UAE has blocked the iMessage feature (they have blocked FaceTime) or wether there is a glitch with my UAE APPLE ID on Apple Server…

    Once iOS 6.1 update is out, I will once again try setting up iMessage with my UAE Apple ID that I normally use and see if it works….

    Hope this will help other people in Dubai, UAE if their iMessage is not working properly.

    Thanks
     

Share This Page