iMessages not sending, but they are

murdoc158

macrumors regular
Original poster
Jan 8, 2007
217
1
West Bend, WI
I've been sending iMessages all day and they are all coming up with a red ! next to them saying "undelivered". The people I'm messaging are getting them too. I'm sending from both my iPhone and my mac using Messages Beta. Anyone else having this issue?
 

eclipse01

macrumors 68020
May 16, 2011
2,449
241
Eau Claire, WI
I've been sending iMessages all day and they are all coming up with a red ! next to them saying "undelivered". The people I'm messaging are getting them too. I'm sending from both my iPhone and my mac using Messages Beta. Anyone else having this issue?
this happens from time to time with me too
 

chuges

macrumors member
Oct 31, 2011
93
8
occasionally happens to me too. and then when I try to resend it they end up getting pissed at me because they receive like 3 copies of the same message
 

Bossyman

macrumors member
Oct 18, 2011
98
3
Go to settings, messages, receive at, apple id...

Sign out

Wait 10 seconds.

Sign back in

Sounds weird, but worked for me on a different iMessage issue.
 

antseg

macrumors member
Mar 10, 2012
50
0
New Jersey
That happened to me once recently. I went into Airplane mode for a few minutes and then turned Airplane off and it stopped giving me problems.
 

beady

macrumors newbie
Oct 13, 2011
25
0
I've had this problem for the past few days. I thought it may have been my wifi network but having the same issue on other networks.

Seriously disappointed with imessage, it just seems like problem after problem
 

Small White Car

macrumors G4
Aug 29, 2006
10,889
1,125
Washington DC
Yes, not working is one thing. Lying to me about what it's done is just terrible, though. It's pretty much unusable if you can't trust what it's telling you.