iMessages not sending

Discussion in 'iOS 5 and earlier' started by SaMaster14, Feb 2, 2012.

  1. SaMaster14 macrumors 6502

    Joined:
    Aug 23, 2010
    Location:
    Los Angeles, CA
    #1
    Not sure why, but today I tried to iMessage a couple of people on WiFi with my iPod Touch and on both I got a 'Message Failure' with a red exclamation next to the message.

    I thought it might have been a wifi issue so I went on my iPad on 3G only and tried sending the messages. Same thing happened...

    On both devices I turned iMessage off and turned it back on, verifying my email/password and restarted the devices. Tried again... nothing.

    Any help? Anyone else having these problems?
     
  2. macbook pro i5 macrumors 65816

    macbook pro i5

    Joined:
    May 13, 2011
    Location:
    New Zealand
  3. SaMaster14 thread starter macrumors 6502

    Joined:
    Aug 23, 2010
    Location:
    Los Angeles, CA
    #3
    Is this a recent issue for you too? My iMessage was working for a while (since iOS5 was released), and it just recently started to act up on me. It was working with iOS 5.0.1 too, so that software update didn't do anything.
     
  4. macbook pro i5 macrumors 65816

    macbook pro i5

    Joined:
    May 13, 2011
    Location:
    New Zealand
    #4
    yes it was just recently now that i think about but this fixes its self then gets broken again even if the other person is connected to wifi.Apple fix this!!!!!!
     
  5. Cell-666 macrumors 6502

    Joined:
    May 3, 2011
    #5
    I have recently been having problem too. I feel it's nothing to do with your phone of the recoevers most mostly, I feel it's Apples server which is the problem.
    I seem to get messages clumped together too which is highly annoying. You'll be talking to someone then it seems as if they are ignoring you, but then get several messages all in one go. Server problem !
     
  6. Nicolas4ever macrumors 6502a

    Nicolas4ever

    Joined:
    Jul 7, 2010
    #6
    Me too.I came up with this problem..I just can't send any message.I don't know what's wrong i hope it's apple's fault so they can fix this.
     
  7. beady macrumors newbie

    Joined:
    Oct 13, 2011
    #7
    I've had this problem for a few weeks now.
    I can send to peoples apple ids but not their phone numbers.
    I'm only receiving imessages from people that use my apple id, if they use my phone number the message doesn't come through.
    I'm also stuck on "waiting for activation.."

    Full restore did nothing but I've read on other forums that people that have restored from a backup which is older than about a month have had some luck.

    Sounds like an apple server problem. I've given up on playing around with the settings, hopefully this is fixed in 5.0.2.
     
  8. bcburrows macrumors 6502

    bcburrows

    Joined:
    Mar 25, 2009
    Location:
    Bristol
    #8
    Also had the same problem. I can send text messages but iMessages are intermittent in their sending / delivering and in particular their speed. I am on the O2 network in the UK. Many of my friends report the same issue - on various network. Presume it must be some sort of apple problem?
     
  9. SaMaster14 thread starter macrumors 6502

    Joined:
    Aug 23, 2010
    Location:
    Los Angeles, CA
    #9
    Maybe is an ipod/ipad to iphone problem. I only send iMessages to people with iPhones (so I send to their phone #s).

    Hopefully this gets sorted out quickly. It's quite annoying.
     
  10. macbook pro i5 macrumors 65816

    macbook pro i5

    Joined:
    May 13, 2011
    Location:
    New Zealand
    #10
    Sometimes it doesn't even send to other iPhones either
     
  11. /user/me macrumors 6502

    Joined:
    Feb 28, 2011
    #11
    Have you tried a restore? I had the same issue, and that fixed it for me :)
     
  12. troop231 macrumors 603

    Joined:
    Jan 20, 2010
    #12
    I also have had trouble with iMessages from the start, it works randomly sometimes won't send or sends hours later, and I'm on WiFi almost all of the time. It's so troublesome that I've just reverted to switching back to SMS permanently! Maybe Apple can't handle the volume of iMessages.
     
  13. scott523 macrumors 6502a

    Joined:
    Sep 8, 2006
    Location:
    Saint Charles, MO
    #13
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I don't know if this is related, but iCloud may have had an outage in the past 30 minutes. My iCloud mail wasn't being pushed and had to be fetched manually.

    Edit: Several email requests I made 30 minutes ago are now being pushed in one at a time like a backlog still exists.
     
  14. SaMaster14 thread starter macrumors 6502

    Joined:
    Aug 23, 2010
    Location:
    Los Angeles, CA
    #14
    I tried seeing if a sync with my Mac would fix the problem, but that didn't work either. And I tried adding new email addresses and turning iMessage on and off and still nothing.

    Very odd... just stopped working out of the blue.

    Maybe a new iOS update will fix this?
     
  15. white4s macrumors 65816

    Joined:
    Nov 15, 2011
    Location:
    New Jersey
    #15
    imessage is becoming a joke with all these baby issues
     
  16. SaMaster14 thread starter macrumors 6502

    Joined:
    Aug 23, 2010
    Location:
    Los Angeles, CA
    #16
    Well, did a little test and it looks like I can send iPad to iPad (and iPod touch to iPad) perfectly fine. But when sending from my iPad or iPod to an iPhone it never works anymore.
     
  17. BubbaJones macrumors regular

    BubbaJones

    Joined:
    May 13, 2004
    Location:
    East Coast
    #17
    Three days ago I couldn't send any iMessages from my iPad. Rebooted, changed DNS servers, disabled and reenabled iMessages... Nothing.

    I was tethered, but it had worked in the past. Once I got back home, and on regular wifi, everything worked again.

    Haven't had the problem since.

    Is there any way to check the state of Apples servers? I assume that iMessage is being piped through their machines.
     
  18. rbgatti macrumors member

    rbgatti

    Joined:
    Nov 1, 2011
    Location:
    USA
    #18
    I would be interested in this also as it seems push mail functioning timely is dependant on their servers too.
     
  19. Grayburn macrumors 68000

    Grayburn

    Joined:
    Jul 12, 2010
    Location:
    London, England
    #19
    I'm on O2 as well and have gotten fed up with it sometimes taking up to 10 minutes to send an iMessage.

    I've now had iMessage turned off for a few weeks now, back to the normal text messages!
     
  20. bcburrows macrumors 6502

    bcburrows

    Joined:
    Mar 25, 2009
    Location:
    Bristol
    #20
    That was my solution - seems to work fine now
     
  21. msmith212 macrumors newbie

    Joined:
    Nov 20, 2012
    #21
    Problem with imessage

    I had the same problem I just changed my apple i.d. password and turned my imessage off for a minute then cut it back on and it started to work again.
     

Share This Page