iMessages not syncing properly between Mtn. Lion & iOS6?

Discussion in 'iOS 6' started by spotsphill, Oct 1, 2012.

  1. spotsphill macrumors regular

    Joined:
    Sep 26, 2009
    #1
    So a few weeks ago I was surprised to see my iMessages mostly syncing between my iPhone and my MacBook. I haven't been able to figure out why the sync is not always 100% effective.

    Basically, I send messages and sometimes they sync and sometimes they don't. I probably need to explain this further, but I honestly haven't been able to pinpoint any kind of consistent cause to the sync/lack of sync. Does anyone have an explanation? I've seen other threads where they talk about disappearing messages -- this hasn't been the case with me. There are just some messages that aren't showing up on my MacBook app, leading to incomplete message threads.

    Thanks!
     
  2. mnsportsgeek macrumors 65816

    Joined:
    Feb 24, 2009
    #2
    I have the same scenario. I don't think it's as streamlined as it needs to be yet, unfortunately.
     
  3. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #3
    Caller ID / Start Convo With

    Is your Caller ID set up as your mobile # on all devices?
     
  4. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #4
    My understanding is that this cannot be done on Mountain Lion (ie - you cannot use your mobile number as a caller ID on the computer). I have tried repeatedly to no avail. I have also tried adding my phone number as an email address (__ATT#__@txt.att.net) but when the verification iMessage is sent to the iPhone it is unable to be verified.

    Has anyone been successful in getting true cross-platform iMessage syncing?
     
  5. sixxmum macrumors 6502a

    sixxmum

    Joined:
    Aug 15, 2010
    #5
    I have my phone set up in Mountain Lion on two computers. But, there are still some issues with syncing well.
     
  6. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #6
    Do you have AT&T? Could you share how you did that? I guess this iMessage thing is just not fully developed yet from what I've been reading online. Disappointing...
     
  7. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #7
    10.8.2 enables use of your phone # with your apple ID. Disable iMessage on your macbook and turn it off on your iPhone. Turn it back on on your iphone and wait for it to activate. Once this is done turn it back on on your mac and you should get a popup saying your phone # has been added to your mac. Make sure you set it as the start new conversations from address and you should be good.
     
  8. sixxmum macrumors 6502a

    sixxmum

    Joined:
    Aug 15, 2010
    #8
    Actually, once I added iMessage on my phone and had the cloud enabled on the computers, I got a popup asking if I wanted the phone number added on the computers.

    It can't be done in Lion, only Mountain Lion.

    If you go into message preferences, click on "add email" but then type in a phone number instead, it will send a validation to that phone and you'll go from there.

    And, now I tested this with my husband's phone number so I could post it to you and can't figure out how to remove it. Ha!
     
  9. shurcooL macrumors 6502a

    Joined:
    Jan 24, 2011
    #9
    This. Same here.
     
  10. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #10
    Interesting. I followed the steps (I had already updated to 10.8.2 but I signed out and back in on my Mac/iPhone) and now it looks like it should work (ie - my phone number shows up on my Mac). Now I'll send a bunch of people messages and see how it works.

    Thanks swordfish.
     
  11. swordfish5736 macrumors 68000

    swordfish5736

    Joined:
    Jun 29, 2007
    Location:
    Cesspool
    #11
    After I made the switch I told people I talked to to delete our old conversation just incase my email address was still the caller id
     
  12. mape2k macrumors regular

    Joined:
    Apr 18, 2011
    Location:
    Germany
    #12
    I also have some issues with synching. Sometimes it takes about an hour to receive the messages on my Mac, sometimes they come in the wrong order and so on...but its nothing major, hopefully Apple will continue to improve this.
     
  13. F1 Fan macrumors regular

    F1 Fan

    Joined:
    Apr 18, 2012
    Location:
    UK
    #13
    Sorry to resurrect an old thread but I'm having this issue on my new mac. Any progress anyone?
     
  14. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #14
  15. F1 Fan macrumors regular

    F1 Fan

    Joined:
    Apr 18, 2012
    Location:
    UK
    #15
    I didn't think that would work since I've been using iMessage on my phone for some time and have just bought my first mac and set iMessage up on it. I tried it anyway, just in case and guess what?... I didn't work.

    My precise symptoms are:

    Some messages show up out of sequence on my mac.
    Most (though not all) of them are stamped with the correct time.
    A few messages haven't shown up at all.

    This is the case for messages sent and receive using my phone both when the mac is on and when it is off.

    Any more advice?
     
  16. aDRock1154 macrumors 65816

    aDRock1154

    Joined:
    Nov 15, 2011
    Location:
    Ohio
    #16
    I just followed these steps the other day. My iMessage wasn't synced up properly and this corrected the issue:

    iMessage and FaceTime

    1. Open Messages app
    2. Go to preferences.
    3. Sign out of the iMessage account.
    4. Go to your iPhone, Sign Out of both iMessage and Facetime. Anything within the Message and Facetime section on the iPhone. TURN IT ALL OFF.
    5. Restart the iPhone.
    6. Turn on FaceTime & then turn on iMessage in your iPhone only.
    7. Once the iPhone activates FaceTime & iMessage. You should receive a popup on your Mac.
    8. The pop up will list the e-mails and not the phone number. No worries..
    9. Go into Messages preferences and log into the iMessage account.

    Once logged into Messages and the iMessages account, you should received 2 or 3 pop-ups that say the phone number was added to FaceTime and iMessage.
     
  17. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #17
    Anytime my Mac gets out of sync with my iDevices, doing those steps fixes it.
    Same for poster above me ^^ (His steps are the same as I linked)

    Any chance you missed a crucial step ?
     
  18. aDRock1154 macrumors 65816

    aDRock1154

    Joined:
    Nov 15, 2011
    Location:
    Ohio
    #18
    Sorry, I honestly didn't even check the link. I didn't realize I reposted the same steps lol


    Either way, doing this will fix all.
     
  19. F1 Fan macrumors regular

    F1 Fan

    Joined:
    Apr 18, 2012
    Location:
    UK
    #19
    I tried it twice because I realised that first time I only turned iMessage off not all the other toggles. 2nd time, I definitely turned ALL the toggles off.

    To clarify...

    Step 3 - Should I close Messages after signing out?

    Step 5 - I turned it off and then back on. Should I have held the power and home buttons to reset it?

    Step 6 - Open to interpretation. I read this as turn on both Facetime and iMessage on the phone without turning either on on the mac. Should I turn on Facetime on the mac before turning iMessage on the phone?


    I have just tried this process for the third time but still no joy. I get no pop up on my mac after 5 - 10 minutes but when I signed in, I got the popups on my phone. The whole time, my phone number and email address have been attached to iMessage on both devices with outgoing messages being sent from my phone number.

    If it helps, I'm running OS X 10.8.3 and iOS 6.1.3. My hardware is in my sig.
     
  20. sim667 macrumors 65816

    Joined:
    Dec 7, 2010
    #20
    Its never worked.

    They rushed it out too fast.
     
  21. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #21
    It has never worked properly for me on the mac. Apples bugs are so annoying. They don't acknowledge them until they finally fix them :mad:
     

Share This Page