Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Aboo

macrumors 65816
Original poster
Jul 7, 2008
1,017
110
I like many others upgraded to iOS 17.1 yesterday. I also upgraded my Mac to the newest version of OS Sonoma. Since doing so, I’m noticing that both on the Mac, as well as on the iPhone, I am unable to send iMessages. I seem to be able to receive them fine however, when sending, I got a red exclamation mark Stating “failed to send“. The phone seems to automatically resend it as a regular text message. I tried resetting the network settings. I tried turning on an off airplane mode. I also hard rebooted the phone without avail. Thoughts on what could be going on?
 

Bigwaff

Contributor
Sep 20, 2013
1,963
1,287
First, on iPhone > Settings > iMessage > (turn off) and then
on Mac > menu Messages > Settings... > iMessage > (Sign Out) of Apple ID

Now, reverse.. on iPhone (turn on) iMessage and then on Mac (Sign In) Apple ID in Messages > Settings.
 
  • Like
Reactions: twanj

Aboo

macrumors 65816
Original poster
Jul 7, 2008
1,017
110
Thank you, I just tried your suggested steps, but no luck. I do have more than one Mac that I am signed into. Do I have to sign out of each Mac?

Thank you!
 

Aboo

macrumors 65816
Original poster
Jul 7, 2008
1,017
110
Just to provide an update - I reached out to Apple and after extensive troubleshooting, they have escalated the issue to engineering. Interestingly, things seem to work fine on a Mac that has not been upgrade to Sonoma, but only specifically being blocked on Macs with Sonoma 14.1 and iOS 17.1.

Unfortunately, this situation has just shown me how dependent on iMessage I am through the course of both personal and professional interactions in life!

I will update back when I get any further input from Apple's engineering team.
 

Aboo

macrumors 65816
Original poster
Jul 7, 2008
1,017
110
Still no updates from Apple engineering. Have had them check to see if my phone numbers or email addresses were inadvertently added to the blocked list, and that is not the issue. If anyone has thoughts, please help :)
 
  • Like
Reactions: twanj

Bigwaff

Contributor
Sep 20, 2013
1,963
1,287
Have you tried Erase All Content and Settings then restore from backup?
 

twanj

macrumors 65816
Sep 10, 2015
1,176
1,634
Pompano Beach, FL
I've been having Messages issues as well since 14.1.

Everything's fine on my phone, but not all Messages are coming thru on my MBP.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.