iMessages occasionally sent as SMS?

Discussion in 'iOS 5 and earlier' started by kockgunner, Oct 14, 2011.

  1. kockgunner macrumors 68000

    kockgunner

    Joined:
    Sep 24, 2007
    Location:
    Vancouver, Canada
    #1
    Sometimes I message people with iMessage and it's flawless, but other times it will only default to SMS. Does anyone know why this happens?

    Also, when you start typing people's names in the recipients field, usually there are blue bubbles beside the people who have iMessage. However sometimes the bubble is gone and when I click on the person, the send button is green (meaning it will be sent as SMS) for a few seconds before it turns in to the blue iMessage button. :confused:
     
  2. xraydoc macrumors 604

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #2
    While I haven't worked out all the ins & outs of iMessage yet, either, I believe it sometimes takes a second or two to verify the availability of internet access of your recipient's iPhone - so it starts off as an SMS and switches to a iMessage if it can.

    There may be situations where the recipient doesn't have internet access (i.e., roaming on another cell network) where voice & SMS will come through but data may not. No point in sending an iMessage over the internet if the recipient can't get it. In those situations, an SMS is preferred, so the iMessage app checks first.
     
  3. kockgunner thread starter macrumors 68000

    kockgunner

    Joined:
    Sep 24, 2007
    Location:
    Vancouver, Canada
    #3
    Everyone I iMessage has an iPhone and data though so I don't know what's going on. I hope things get sorted out because I really want to just go iMessage and maybe WhatsApp and save money.
     
  4. elfy macrumors 6502

    Joined:
    Apr 26, 2011
    Location:
    Glasgow, Scotland
    #4
    Yeah but it only works over Wi-Fi or 3G, so if they are somewhere where they aren't getting a Wi-Fi or 3G signal then it won't work. You can turn off the option to send as an SMS if you like. Just go to settings>messages>send as SMS and turn it to off. Be aware that they might not get your message straight away though.
     

Share This Page