iMessages send from icloud email instead of phone number!!!

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by MacGit, Mar 1, 2015.

  1. MacGit, Mar 1, 2015
    Last edited: Mar 1, 2015

    MacGit macrumors newbie

    Joined:
    Jul 15, 2008
    Location:
    Manchester, England
    #1
    This is a long-standing issue that defies resolution. At times, my iphone or my wife's iphone will send iMessages from our iCloud addresses instead of our phone number. So if my wife sends an iMessage to me, I sometimes get a new message from "julie.surname@icloud.com". Although her name, email addresses and phone number are in my Contacts, this new conversation shows up as her email address. We used to think it was because she travels abroad and uses wi-fi in her hotel that caused the phone to use an email address rather than her number because she was out of the UK. Not so! Here's what happened today: My wife sent me and our 2 children iMessages from London Heathrow to us three at home. My message came through as from her email address, my daughter's also came through from her email address, but my son, a few yards down the hallway got his from her phone number.
    *
    This is a typical scenario which can work the other way round when it's ME sending her the iMessages where she gets my message as though I'd sent it from my email address rather than the phone number. So on each iphone we have 2 conversation threads - one with the email address and the other with the phone number! On each phone we have only 1 Contact entry in the 'book', so it's not like it's being duplicated because the contact is entered twice.
    *
    I have been through all the hoops I know of to sort this but I just can't fix it. I don't know whether it's the iPhone, iCloud or what that's at fault. But it is driving me mad.
    *
    In this morning's case, I replied to her message by using an older (yesterday's) conversation to send my iMessage to her, and her reply to that came to me via her phone number, as expected, and good as gold. Had I just replied to her iMessage, it would have perpetuated the TWO conversations. I have tried logging out and back in, deleting the accounts and reinstating them, re-entering the settings, making sure that the "Start new conversations from..." is set up correctly and so on. Then after a while, it returns, randomly, to sending texts from the email and starts a new conversation again. And you can't combine the 2 conversations even when you go to Details-Add to existing contact etc.
    *
    I have also just been informed by a supplier that my iMessages to him are showing up as my email address not my phone number, despite my iphone being set to 'Start conversations from +44777...etc"
    *
    Please throw out suggestions as you wish and I'll be grateful, even if it's one I've already tried and failed with.
    *
    This icloud is a nightmare.
    *
    Many thanks in advance.
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #2
    I get this sometimes and it is annoying. I think it's a fluke on apples servers nothing that has to do with our phones.

    It randomly did it the other day when Imessaging one friend of mine but not others. Deleting the convo and starting it over corrected the issue.
     
  3. kissfan macrumors member

    kissfan

    Joined:
    Dec 7, 2011
    Location:
    Florida
    #3
    Which side of the conversation did you have to delete? The one with the incorrect source account or the one originating the message? Or both?
     
  4. MacGit thread starter macrumors newbie

    Joined:
    Jul 15, 2008
    Location:
    Manchester, England
    #4
    Thanks guys. In the past I deleted the thread that was spawned by the email address. But sooner or later you get another imessage from their email address and so the frustration starts all over again. Also, at times, it presents itself in the proper name of the contact but still starts a new conversation! So this bogus thread goes on for a while before realising it's a separate and new thread from the original, long-standing one. Sometimes with important info included, or photos, so it's annoying to have to delete the thread and lose all that stuff. Wouldn't be so bad if you could merge the 'wrong' thread into the original one.
     
  5. kds1 Suspended

    kds1

    Joined:
    Feb 17, 2013
    Location:
    New York, New York
    #5
    Wait. Just set your phone number as the only address you can be reached at for iMessage.
     
  6. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #6

    Deleted both to make sure
     
  7. newagemac macrumors 68020

    Joined:
    Mar 31, 2010
    #7
    Did you set your phone number as default? You have to do that. Also, if someone selects your email address to text you, there is no preventing that unless you set your phone number as the only way you can be reached for iMessage.
     
  8. MacGit thread starter macrumors newbie

    Joined:
    Jul 15, 2008
    Location:
    Manchester, England
    #8
    Yes of course. Trust me, I've done all that and double-checked that all the settings are absolutely spot on. That's why this is so frustrating. Even took both our iPhones into the Apple Store Genius to treble-check our double-checked settings. Signed out, signed in, deleted, re-installed, the lot. I am now arriving at the conclusion that it is Apple's fault on their servers as someone has already suggested on here (thank you). It happens entirely randomly on the same phones with the same settings when nothing has changed apart from the time and date since it last happened.

    Go figure. Thanks for responding.
     

Share This Page