iMessages sent to phone number in OSX

bigjnyc

macrumors 603
Original poster
Apr 10, 2008
6,396
3,467
So since upgrading to ML 10.8.1 I am getting imessages sent to my phone number on my iPhone and on my desktop imessage application. This is not such a huge deal except that whenever I turn on my computer I start getting all the imessages I had received since the last time I turned it on. I dont understand why these are flowing in if I already read them on my phone.

Is there anyway to limit iMessages on the desktop to messages received to my email and not to my phone number?
 

southerndoc

macrumors 65816
May 15, 2006
1,081
60
USA
Unfortunately this is a design flaw with Messages. Report it at www.apple.com/feedback and ask that Apple fix it. I have a feeling it's going to take a lot of effort to fix it.

It's really annoying when you have your laptop off for a few days and then boot it up only to receive about 100 texts.
 

bigjnyc

macrumors 603
Original poster
Apr 10, 2008
6,396
3,467
Oh man thats horrible. I'm considering removing my iMessage account from Messages because of this. its quite annoying.

Thanks for the info.
 

jk73

macrumors 6502
Jul 19, 2012
471
119
Unfortunately this is a design flaw with Messages. Report it at www.apple.com/feedback and ask that Apple fix it. I have a feeling it's going to take a lot of effort to fix it.

It's really annoying when you have your laptop off for a few days and then boot it up only to receive about 100 texts.
You mean the texts that have already been read are showing up as new, unread messages? If I read a message on one device, it's marked as read almost simultaneously on the other.
 

southerndoc

macrumors 65816
May 15, 2006
1,081
60
USA
You mean the texts that have already been read are showing up as new, unread messages? If I read a message on one device, it's marked as read almost simultaneously on the other.
No, if you have your desktop or laptop asleep and then boot it up, any texts you receive on your phone through iMessage will come through in the notification center. At least that's what happens with my MacBook Aluminum (now retired), new MacBook Air, and my iMac.
 

lpeedin

macrumors regular
Nov 4, 2011
193
1
No, if you have your desktop or laptop asleep and then boot it up, any texts you receive on your phone through iMessage will come through in the notification center. At least that's what happens with my MacBook Aluminum (now retired), new MacBook Air, and my iMac.
That is NOT happening with me. I usually put my MBP to sleep just before dinner. During the evening, I may have numerous iMessages via my iPhone. When I wake my MBP the next morning, the messages will be there but I will not get any notification.
 

bigjnyc

macrumors 603
Original poster
Apr 10, 2008
6,396
3,467
That is NOT happening with me. I usually put my MBP to sleep just before dinner. During the evening, I may have numerous iMessages via my iPhone. When I wake my MBP the next morning, the messages will be there but I will not get any notification.
Thats odd, I'm getting the notifications as well. They all come streaming in as soon as I wake up my computer. Even if I already read them on my phone.... Maybe I can just turn off notifications for iMessages.
 

kmj2318

macrumors 68000
Aug 22, 2007
1,606
551
Naples, FL
Seems like we have opposite problems, I'm wondering how you were able to get text messages received on your computer in the first place :)
 

aziatiklover

macrumors 68030
Jul 12, 2011
2,661
94
8.8.8.8 and 8.8.4.4
Thats odd, I'm getting the notifications as well. They all come streaming in as soon as I wake up my computer. Even if I already read them on my phone.... Maybe I can just turn off notifications for iMessages.
Yeap I'm having the same issue with my mac mini! Everytime I turn it on (once a week. I use my ipad daily) i get all the imessages popping forever from monday to the latest one. It gets annoying! :apple: needs to get this fix.

Gowever, I heard with iOS 6 between iOS devices it will show as read on other devices. So we will see if that will fix this issue for osx once iOS 6 is released.
 

BaldiMac

macrumors 604
Jan 24, 2008
7,410
6,815
iMessages to your phone number on a Mac aren't officially supported until iOS 6 and OS X 10.8.2 are released, so that might be part of the problem.
 

bigjnyc

macrumors 603
Original poster
Apr 10, 2008
6,396
3,467
Seems like we have opposite problems, I'm wondering how you were able to get text messages received on your computer in the first place :)
It wasn't happening until I updated to OSX 10.8.1
 

lpeedin

macrumors regular
Nov 4, 2011
193
1
Here's what I am seeing. Anyone who I have instigated a conversation with using Messages on my MBP gets synced between my 2 devices as I described above. However, individuals that I have only conversed with via the iPhone do not sync with the MBP.

Also, no part of the conversation before the MBP instigated conversation took place is synced - just new messages.

I fully expect that Apple is still working on this and we won't see full Message integration until iOS 6 is out and both iOS and OSX have had a couple of minor updates.

But I'm really looking forward to the finished product.
 

BaldiMac

macrumors 604
Jan 24, 2008
7,410
6,815
Here's what I am seeing. Anyone who I have instigated a conversation with using Messages on my MBP gets synced between my 2 devices as I described above. However, individuals that I have only conversed with via the iPhone do not sync with the MBP.

Also, no part of the conversation before the MBP instigated conversation took place is synced - just new messages.

I fully expect that Apple is still working on this and we won't see full Message integration until iOS 6 is out and both iOS and OSX have had a couple of minor updates.

But I'm really looking forward to the finished product.
The difference is in the address that you are iMessaging from. Currently, you can iMessage using your phone number OR your AppleID email address as the reply to address from an iPhone. However, iMessage on the Mac (and iPad and iPod touch) currently only supports your AppleID email address, so only messages sent to/from your email address will sync onto the Mac.

However, when iOS 6 and Mac OS X 10.8.2 are released, you will be able to tie your phone number to your AppleID. That way all iMessage conversations will sync to all devices.
 

swordfish5736

macrumors 68000
Jun 29, 2007
1,898
104
Cesspool
if you open up preferences for messages you should be able to uncheck your phone number from the you can be reached at field.

this is one of the things that powernap is nice for..I leave imessage open on my air and as long as its in range of one of the wifi networks i connect to it receives all the messages while its asleep
 

jk73

macrumors 6502
Jul 19, 2012
471
119
if you open up preferences for messages you should be able to uncheck your phone number from the you can be reached at field.
Under 10.8.1, that preference pane only accepts email addresses. Right now, phone numbers and AppleID are linked via the prefs pane on one's iPhone.
 

bigjnyc

macrumors 603
Original poster
Apr 10, 2008
6,396
3,467
Under 10.8.1, that preference pane only accepts email addresses. Right now, phone numbers and AppleID are linked via the prefs pane on one's iPhone.
Thats correct. I was surprised to receive messages sent to my number since preferences only lists my emails.
 

swordfish5736

macrumors 68000
Jun 29, 2007
1,898
104
Cesspool
Thats correct. I was surprised to receive messages sent to my number since preferences only lists my emails.
Are you running iOS 6 on your iPhone? With 10.8.2 you have to option to deselect your phone number. Interesting that it showed up for you in 10.8.1
 

iRobby

macrumors 6502a
Mar 22, 2011
994
5
Fort Myers, FL USA
So since upgrading to ML 10.8.1 I am getting imessages sent to my phone number on my iPhone and on my desktop imessage application. This is not such a huge deal except that whenever I turn on my computer I start getting all the imessages I had received since the last time I turned it on. I dont understand why these are flowing in if I already read them on my phone.

Is there anyway to limit iMessages on the desktop to messages received to my email and not to my phone number?
If I understood the keynote correctly this is how it should work. It is syncing to your Mac incase you want to continue the conversation on the Mac.

The only way to stop the sync is to close the conversation on your iOS device before going to your Mac so the cloud knows you ended the conversation.
 

ProphetX

macrumors 6502
Feb 8, 2011
354
102
This is not a design flaw. Its how its supposed to work. Sync'd means sync'd. And you have to pay attention to details...

When you read a text on your iphone and then go to your computer, yes the messages start flowing in. But they aren't new messages.