iMessages/Text

Discussion in 'iPhone Tips, Help and Troubleshooting' started by london12, Jul 31, 2016.

  1. london12 macrumors newbie

    Joined:
    Jul 31, 2016
    #1
    For the record I know imessages need the internet or wifi to send as imessages. But shouldn't imessages send as text right away if you don't have the internet? I find it appalling that both Verizon and Apple answers so far have been you should be on the internet all the time.

    The person sending the imessage will send theirs but I will not get them until hours later when I get on wifi. Likewise I can't send mine so I'll send it as a text. But the receiving person will tell me that I send two messages. I'm assuming this is an Apple problem because it's just with iphones.
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Send as SMS needs to be enabled in settings>messages. It is not by default

    IMG_0589.PNG

    Alternatively you can tap and hold the message your trying to send and select send as text.

    The above setting will send if the message either fails or times out in iMessage.
    --- Post Merged, Jul 31, 2016 ---
    Side note, spotty iMessage issues whilst on carrier data isn't unheard of to be honest.
     
  3. MiniGeek macrumors member

    Joined:
    Apr 10, 2016
    #3
    I've had that issue as well receiving iMessages when I am traveling outside my home country and have data shut off on my iphone. It occurs in situations where I have an iPad sitting somewhere still connected to the internet with a wifi connection. The iPad receives the iMessage because it is on the internet, so as far as iMessage is concerned, the message has been delivered to me. My iPhone won't get it until it is back on the internet via wifi. If I'm in a situation where the iPad is not on the internet, then the iMessages do eventually get to me as text, but there is a delay until iMessage figures out that it can't deliver the message that way, then it kicks it over to text. Yes, it's a nuisance. If I start the conversation and long press the message right away to send as text, I tell my Apple recipient to do the same in the reply, and then the conversation takes place as text messaging and there's no delay.
     

Share This Page