iMessages, what am I missing?

NJFP

macrumors 6502
Original poster
Feb 18, 2009
342
25
Running public beta 9.3.2 on my iPhone 6S+ and my iPad Pro. Before this version, when texting on my phone it automatically dinged on my IPP and vice versa. Not so anymore. Is there a setting I'm missing? I don't remember changing anything in settings to cause this. Don't' want to keep stopping things on my IPP to pick up my phone to reply to texts. Thanks in advance for any help!
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,503
16,010
Are you signed in with the same Apple ID on both devices? Is iMessage enabled on both devices? Are these definitely iMessages and not regular text messages?
 

NJFP

macrumors 6502
Original poster
Feb 18, 2009
342
25
Yes, yes and yes. I could have sworn that when I first set up my IPP, it had checked an option to start messages from my cell phone's number. That's no longer there. And yes, my IPP is cellular/wifi on the Verizon network.
 

chuyn

macrumors 6502
Nov 13, 2015
365
108
You've already tried signing out/in or turning iMessage on/off?

I had an issue like this in the past, and back then, the problem was I unchecked (or deleted, I can't remember exactly) my email address under the "You can be reached by iMessage at" section on my iPhone. When I did that, for some reason my phone number wouldn't show up under the "Start new conversation from" section on my iPad. Once I had the email show on both devices, they synced and I was able to choose my phone number on the iPad again.
 

NJFP

macrumors 6502
Original poster
Feb 18, 2009
342
25
You've already tried signing out/in or turning iMessage on/off?

I had an issue like this in the past, and back then, the problem was I unchecked (or deleted, I can't remember exactly) my email address under the "You can be reached by iMessage at" section on my iPhone. When I did that, for some reason my phone number wouldn't show up under the "Start new conversation from" section on my iPad. Once I had the email show on both devices, they synced and I was able to choose my phone number on the iPad again.

BRILLIANT! That was the problem. All is well, thank you!!!