iMessaging ~ Is it being mismarketed or misunderstood?

Discussion in 'iPhone' started by KittyKatta, Oct 25, 2011.

  1. KittyKatta macrumors 6502a

    KittyKatta

    Joined:
    Feb 24, 2011
    Location:
    SoCal
    #1
    I apologize if I'm missing something obvious here, but iMessaging just isnt working the way I thought it would. I have an iPad and iPhone and based on marketing/demos then I thought that texting anyone on an iOS device would result in a nice long thread that would synchronize between both devices but I'm not getting that at all. I can iMessage other iOS devices from the iPad but they don't synchronize to show complete logs and on my phone then any iPhone to iPhone texts aren't showing up on the iPad so I cant really continue from a different device.

    This isnt about basic troubleshooting because they're on the same apple ID and contacts do contain both the text and apple id for each person so I think its more about the concept. Ive talked to many others just as lost as me and concluded that either we're misunderstanding the iMessaging concept or Apple is marketing it too simplistic when it is actually a fairly jumbled concept that doesnt really combine Text with iMessages. So if anyone can point out what I'm doing wrong I'd appreciate it.
     
  2. Joshitect macrumors member

    Joined:
    Oct 7, 2011
    Location:
    Lexington, KY
    #2
    It wont sync text messages, only iMessages. It needs to know what accounts to sync so on your phone you need to have 2 accounts set.

    To make sure you are getting it to sync on both devices you need to go to:

    Settings->Messages->Receive At

    Make sure both your phone # and apple ID are in there on your phone. Make sure your apple ID is on the Ipad.

    All future messages should sync now. I needed to delete the original message for it to start to sync.
     
  3. KittyKatta thread starter macrumors 6502a

    KittyKatta

    Joined:
    Feb 24, 2011
    Location:
    SoCal
    #3
    My settings are right where the appleID is the assigned iMessage default and contacts contain both the appleID and text number. But when I get texts and imessages they show up in different threads and there is no sync between messages sent on one device vs another.
     
  4. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #4
    Two things:

    1. Set your caller ID for iMessage to your email address. This will ensure that any message sent via iMessage from your phone is using your email. The default is to sent your iMessages via your phone number which may cause syncing issues with an iPAD getting the same imessages that your phone gets.

    2. Be sure that all your contacts that have iMessage on your iphone have both a phone number and their iMessage email address. This way your phone always knows that an email from Jane Doe and a text message from Jane Doe belong in the same thread.

    As a side note, true texts will not sync. However, if using the above items then any iOS using your appleid will be synced.
     
  5. goofy1958 macrumors regular

    Joined:
    Oct 7, 2011
    #5
    One other thing to understand, all of your devices, and everyone you send to must be using IOS5. If your texts are blue in color, then you are using iMessage to send, if it is green, you are using SMS to send the texts, and they will not be synched no matter what you do.
     
  6. GraphicsGeek macrumors 6502a

    Joined:
    Sep 19, 2008
    #6
    X2 on setting your iMessages caller ID to your email address. You are sending messages via your phone number and Apple ID. I don't know why it doesn't group iMessages by contact name instead of Apple ID/phone number.
     

Share This Page