iMesssage and FaceTime won't activate

Discussion in 'iOS 5 and earlier' started by ericschmerick, Oct 18, 2011.

  1. ericschmerick macrumors regular

    ericschmerick

    Joined:
    Dec 18, 2004
    Location:
    China
    #1
    OK, this is driving me crazy.

    I live in China. I have three iPhone 4 phones that I bought last year directly from Apple at full retail, factory unlocked.

    I updated all of them to iOS5 on basically the first day the software was released (last week). Got everything set up and going, and for the first full day I was able to send / receive iMessage with my wife no problems whatsoever.

    Then, suddenly I noted that iMessages weren't sending (tried to send an MMS, and it said delivery failed). Checked settings and found that iMessage said "waiting for activation".

    I have tried turning off/on iMessage a billion times. Each time, it activates my email address for iMessage, but not my phone number. Usually each time I turn on iMessage, I get a weird text message that looks like some kind of silent SMS command coming from a UK number (+0044xxxxx, REG-RESP blah blah blah). After a while it says "activation failed" or something like that.

    I made the mistake of turning iMessage off on my other phones, and when trying to turn it back on it does the same thing now.

    On twitter it looks like there are quite some people who also have this problem, though not really a flood.

    WTF. I just flew to Eurpoe (Norway), and it's doing the same thing from here. I have no idea if this is a phone problem, a bug, a carrier problem, Apple's servers being overloaded, what what what. It's been two days now.

    Any ideas?
     
  2. ericschmerick thread starter macrumors regular

    ericschmerick

    Joined:
    Dec 18, 2004
    Location:
    China
    #2
    I just tried yet another restore, this time from DFU mode starting from scratch.

    I'm feeling pretty sure this is a carrier issue. I watched a youtube video a few moments ago about a guy who way trying to get his iMessage activated on Tmobile after a jailbreak. It seems they way to get around it is to modify the called ID of the SMS that the phone is looking for for activation (from +44 blah blah blah to +01144 blah blah blah in his case). I suppose the problem is that China Unicom is mangling the called ID of the activation sms, so that it's coming over as +0044.... instead of +44...

    Actually I've always noticed this problem. When I was in Singapore all my messages came over as +<country code>, but in China they come over as +00<country code>. Screwed up my address book big time, actually.

    I wonder if they will ever get this problem solved then. China = glacial pace to resolve issues like this.
     
  3. lexi8504 macrumors newbie

    Joined:
    Oct 21, 2011
    #3
    Have you gotten this resolved yet? I'm also in China having the exact same issues with iMessage.
     
  4. Bernard SG macrumors 65816

    Bernard SG

    Joined:
    Jul 3, 2010
    #4
    There's a very savvy JB community in China...
    Problem is that iPhone 4s JB is not out yet.
     
  5. anac macrumors newbie

    Joined:
    Oct 17, 2011
    #5
    My problem for FaceTime and iMessage is that when I try to add my emails I can't get them verified as I get a message that " email is already in use". It only takes my id email and my phone

    Any ideas?
     
  6. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #6
    Are the emails you're trying in any way associated with a different AppleID?
     
  7. c1morgan macrumors newbie

    Joined:
    Nov 2, 2011
    #7
    Restore required

    Hello,
    I had this problem with iMessage and FaceTime on my iPhone 4s.

    After much time with a senior advisor with Tech support, they decided my iphone thought it was an ipod (sounds crazy, but this is what they told me).

    I had to do a full RESTORE of my iphone using iTunes. IMPORTANT: You must set up your iphone as a new iphone, do not restore from iTunes. Your apps won't be lost if you sync them prior to the restore. You must also sync photos/videos to your computer or else you will lose them from iPhone during the RESTORE.

    This solved the FaceTime and iMessage problem, they work perfectly now.

    On another note, YouTube and Push Notifications were also not working- every app with Push Notifications was telling me I had to connect to iTunes in order to enable Push, but this did not work. After the Restore, both YouTube and Push Notifcations are fully functional now.

    Hope this helps!
     
  8. glopezpadro macrumors newbie

    Joined:
    May 5, 2010
    #8
    iMessages not activating...

    The problem seems to be with an SMS that the iPhone sends to a server for activation. On its way back somehow the content gets malformed and the command to activate is not processed. This happens hidden to the user, but in my case, I AM receiving said txt/SMS in plain format.

    With my carrier on the phone we have reset EVERYTHING on my side and their side to no avail.

    Frustrating as I just activated 9 other devices from the same batch in my company.
     

Share This Page