IML ineligible music: you must disable IML to sync?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by etm0001, Sep 17, 2015.

  1. etm0001, Sep 17, 2015
    Last edited: Sep 17, 2015

    etm0001 macrumors member

    Joined:
    Apr 4, 2015
    #1
    Hi,

    tl;dr: iCloud Music Library ineligible music can only be sync'ed to an iOS device if IML is disabled. Correct?

    I'm using iOS 9, iTunes 12.3.0. I have MP3 files that are IML ineligible presumably because the bitrate is too low (64kbps, mono channel). After numerous tests, Googling, and reading these forums, I believe it's not possible to sync IML ineligible music when IML is enabled in iTunes and on the iOS device. Correct?

    Clarification: you can disable IML in iTunes and on the iOS device and sync the ineligible files. However, after IML is enabled on the iOS device, the ineligible music is removed (in my case, the music is in a handful of playlists; after re-enabling IML, the playlists are still shown on the iOS device, but they are empty).

    This is incredibly frustrating. {See edit #2 below} The only other solution I can think of is to re-encode the ineligible music to AAC/higher bit rate, which in theory will make the files IML eligible.

    Edit: simply selecting to re-encode to AAC in iTunes is not necessarily enough, depending on the original bitrate of your files. My files are spoken audio and were originally encoded at 96kbps/mono channel. iTunes re-encoded the files to AAC 32kbps/mono, which is...ineligible for iCloud Music Library. Again,this is incredibly frustrating.

    Edit 2: OK I'm an idiot. iTunes re-encoded the original files to 32kbps AAC because that's how I had configured iTunes to import/convert at some point in the past. Re-encoding above 96kbps allowed the files to be uploaded to iCloud. (It's still annoying to have to do this and it's a waste of space).
     
  2. jsmith189 macrumors 65816

    jsmith189

    Joined:
    Jan 12, 2014
    #2
    tl;dr Correct.

    I did that to a few songs. I just converted them up and re-synced.
     

Share This Page