iMovie 08 not opening

Discussion in 'Mac Apps and Mac App Store' started by Larryn75, Mar 19, 2008.

  1. Larryn75 macrumors newbie

    Joined:
    Feb 29, 2008
    #1
    Just upgraded to Tiger, now at 10.4.11... and my new iMovie 08, also just installed (previously had iMovie HD, from iLife 05) won't open at ALL. I've researched & see no real clear answer in any forums here or elsewhere, aside from one idea to Recalibrate the Monitor (!!).
    For the record, I have all the specs: Apple specs minimums are OS 10.4.9, a G5 PowerPC dual 2.0GHz or better (I have that), I GB of memory (have 2.5); need 3 GB of space, have 78 GB. I've also done all updating available.

    So? Should I try to delete and reinstall iMovie only?
     
  2. macsrules macrumors regular

    Joined:
    Feb 26, 2008
    #2


    Back everything up,

    library/mail

    user/library/mail

    user/documents and whatever else you want to keep.


    Zero out the hard drive and re-install the operating system. Do all the Apple Updates, and re-install i-Movie, do all the updates. Launch i-Movie and see if that does not fix the problem
     
  3. fotomiami macrumors newbie

    Joined:
    Dec 27, 2006
    #3
    I have the same problem.
    Tried deleting everything with appzapper and reinstalled, still nothing!

    This is so frustrating. Been without iMovie for several months after upgrading to Tiger. I use a PC to edit home movies now :(
     
  4. robanga macrumors 68000

    robanga

    Joined:
    Aug 25, 2007
    Location:
    Oregon
    #4
    Just in case you did not catch this on another post...

    This was a similar issue that I just fixed that may help you. I found the answer on google. Basically iMovie was launching for me, but there was no main screens showing any projects or editing tools etc.

    The (rather strange) fix for this was to go into preferences for the display and calibrate it. That's it. One calibration and iMovie was back working normally.
     

Share This Page