iMovie '09 Crashes on StartUp

Discussion in 'Mac Apps and Mac App Store' started by nickythecap, Apr 7, 2009.

  1. nickythecap macrumors newbie

    Joined:
    Apr 7, 2009
    #1
    I just purchased iLife '09 and installed on my iMac G5 (1.9GHz, 2.5GB RAM, 160GB HDD). I updated the software to the latest version via Software Update. When I launch iMovie '09, the program appears to load, but when I try to do something (i.e., click a button), I get the spinning beach ball and have to force quit the program. Tried repairing Disk Permissions and such. No effect.

    Any ideas on how to get iMovie working fully?
    Thanks!
     
  2. Old Muley macrumors 6502a

    Old Muley

    Joined:
    Jan 6, 2009
    Location:
    Titletown USA
    #2
    I just tried iMovie 09 for the first time on my new iMac, and the app immediately crashed. After several more attempts to get iMovie to run, I came here looking for advice and saw lots of similar complaints about the program refusing to run. None of the suggested solutions seemed to work, so I ultimately ended up removing iMovie and all associated files from my HD and did a fresh reinstallation. This seems to have worked... for now.

    The version I had that was doing all the crashing was 8.0.3. I'm back to running 8.0.
     

Share This Page