iMovie '09 Crashing on Launch.

Discussion in 'Mac Apps and Mac App Store' started by CBGFilms, Apr 5, 2009.

  1. CBGFilms macrumors regular

    Joined:
    Oct 16, 2008
    #1
    Recently I deleted all of my :apple: iMovie Events (Events NOT Projects) Because it was using about 80GB+ of my HDD space. I deleted these from the finder, not from within :apple: iMovie.

    Now whenever I launch :apple: iMovie it will try to load the events, nothing happens, then searches for :apple: iPhoto movies, then in the video preview window I see an image saying Source Missing.

    I have tried reinstalling :apple: iMovie '09, no luck.
    Help?
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    You do realize that Projects are nothing without the Events right? Because iMovie Projects are based on references to data points in the Events. Only in iMovie 6 and previous versions were the footage and the project in the same file. Drag the iMovie Projects folder to the Desktop and try launching iMovie again. I've also heard of issues with the iPhoto Library causing issues with iMovie. If you already tried reinstalling iMovie I doubt its an issue with the application itself, and more likely a process on the user account that is trying to access data it can no longer find.
     
  3. CBGFilms thread starter macrumors regular

    Joined:
    Oct 16, 2008
    #3
    Problem Resolved

    Yes, I did know that they were nothing without the events, but basically I just wanted to keep the self contained files that are made in the projects once you export.

    But that all backfired now because I moved the Projects out and its fixed, but accidentally deleted them xD ahh well, they're all on YouTube anyway. Atleast the issue is fixed now xD

    :D:D:D:D:p:p:apple:
     

Share This Page