iMovie 09 Doesn't let me import .mov file. Wtf

Discussion in 'Mac Apps and Mac App Store' started by Aniday, Sep 15, 2009.

  1. Aniday macrumors regular

    Joined:
    Jan 27, 2009
    #1
    So I recorded a video with my phone and copied it onto my computer. It was a .3gp file and I converted it into a .mov file with Quicktime X. iMovie 09 does not allow me to import either of these files.

    A while ago I was able to import straight from a .3gp file... but now it wont do either.

    I just find it a little odd that iMovie wont upload Apple's own .mov file.

    Halp.
     
  2. mountweary macrumors newbie

    Joined:
    Mar 26, 2013
    #2
    possible solution

    I just posted this in another thread; re-posting here:

    I was suffering through this issue for ages until I happened upon an unlikely solution: try CHANGING THE FILE NAME. This might sound ridiculously simple, but it worked for me after I went through countless attempts at working around what seemed like an impossible situation.

    It turns out that the forward slashes (/) I had used to identify the .mov files I was trying to import was the problem all along. Nothing indicated this, which is why it took me forever to figure it out (no error message, except for a "-37" error that appeared when I tried to import the same files on my old mac, using an older version of iMovie).

    This was immensely frustrating but I'm glad it's finally resolved. Hopefully sharing my experience here will be of use to someone out there!
     
  3. palmharbor macrumors 6502

    Joined:
    Jul 31, 2007
    #3
    MPEG streamclip

    Download the FREE Mpeg streamclip.
    Drag it into it and convert the .mov to mp4
    Drag into iMovie
    Solved.
     

Share This Page