iMovie 09' endlessly bounces and never opens

Discussion in 'Mac Apps and Mac App Store' started by greg400, Dec 23, 2009.

  1. greg400 macrumors 6502

    Joined:
    Aug 13, 2009
    #1
    Alright, so every time I try to open iMovie '09 (8.0.5) on Snow Leopard (10.6.2) all it does is bounce in the dock never to open no matter how long I wait. I deleted EVERY possible file related to iMovie, repaired disk permissions, scoured through my quicktime codecs to see if there is anything unusual, inserted my applications dvd, re-installed iMovie entirely and it still bounces endlessly. Glad I wasted my time. I'm on the verge of doing a clean install of Snow Leopard since this is really starting to piss me off and I just want to get the problem resolved. Am I missing something here? Why is this not opening even after I clear every cache/plist/whatever file related to iMovie? Every other iLife program I have is opening perfectly fine. Someone please make some sense of this. Also keep in mind that it was working perfectly fine the day prior.
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Oddly enough, this may have to do with iPhoto, especially if you've imported any videos into it from your digital camera. Try creating a temporary new iPhoto Library (by holding option while launching iPhoto), and then launch iMovie. If it opens, you've found your problem; take the recently imported videos out of the original iPhoto library and you're golden. If it does not, then consider clearing the ~/Movies folder of the iMovie Projects and iMovie Events folders, and trying to open iMovie yet again. If it launches, quit iMovie, and copy the iMovie Events folder back in, see if it still launches. Then try something similar with the Projects folder or even individual projects to see if you can't tie it down to a particular damaged project.
     
  3. greg400 thread starter macrumors 6502

    Joined:
    Aug 13, 2009
    #3
    Unfortunately none of those solutions worked. I had no videos in iPhoto but I still made a new library to see if that fixed it and I had already deleted the folders in my Movies folder related to iMovie and those also did not fix the problem.
     
  4. rsm20 macrumors newbie

    Joined:
    Dec 23, 2009
    #4
    I Agree with the above, Thats what did it for me. quiet annoying, sometimes Iphoto when it imports a video from the camera it stops and doesnt do anything! very irritating. I thought it would of been sorted but nope not yet.

    Good Luck.
     

Share This Page