iMovie 1.3 now supports iPAD 1 (original)

INTERNETICUS

macrumors newbie
Original poster
Mar 8, 2012
3
0
believe it or not - iMovie 1.3 now supports iPAD 1 (original)

i just managed to install it through iTunes on my iPAD 1 iOS 5.1 - i double checked it..

thanks Apple ! :)

btw i just hope that iPhoto will also become available on iPAD 1st generation - only happy thoughts :D
 

INTERNETICUS

macrumors newbie
Original poster
Mar 8, 2012
3
0
regular iTunes installation - theres no trick..

click on your iPad in iTunes and go to the applications tab, check iMovie app and then click sync..

i just checked again and it works perfectly..

im using win 7 sp1, iTunes 10.5.3.3, iPad 1 iOS 5.1 and iMovie 1.3
 
Last edited:

sk1wbw

Suspended
May 28, 2011
3,505
982
Williamsburg, Virginia
Not for me it's not. I've tried even dragging the iPhoto icon into the iPad and it still won't work. Installing through iTunes via the iPad won't work for me either.:confused:
 

INTERNETICUS

macrumors newbie
Original poster
Mar 8, 2012
3
0
iPhoto application is compatible with iPad 2 & iPad 3 (The New Ipad) not iPad 1..

im talking about iMovie and suppport for iPAd 1st generation..
 

aka.seim

macrumors newbie
Nov 2, 2011
23
0
Not for me it's not. I've tried even dragging the iPhoto icon into the iPad and it still won't work. Installing through iTunes via the iPad won't work for me either.:confused:
The iMovie app, not the iPhoto ;-)

It seems that Trailers only work on iPad 2.... Can you confirm?

I don't know why they have to limit it...
 

ToddJ

macrumors 6502
May 23, 2008
444
13
I got iMovie to work on my iPad 1, but the 'trailer's' doesn't work though. Is anyone else having this problem?