iMovie 11 - cannot locate source clips, but I know they're there!

Discussion in 'Mac Apps and Mac App Store' started by lolamala, Feb 21, 2013.

  1. lolamala macrumors newbie

    Feb 21, 2013
    This seems to be a common occurrence, but it will not resolve. I have a project in iMovie on my Macbook Pro, and it shows me the yellow "!" triangle. When I holver the mouse over these clips, it says "Source clip is missing" and shows a star in a box icon.
    I know those video clips are in my iMovie Event folder, and are not corrupt files, so PLEASE tell me how I resolve this! It's driving me insane.... I tried deleting the applist file in preferences as everyone on the net seems to suggest, but the problem is still there.
    I also tried hovering the mouse over the yellow warning triangle, but that shows me nothing either.
    I'm at my wits end with this! I need to complete this movie project, and don't want to lose the work I've done (fixing levels, cropping parts, etc) as there's a good few hours work in this.

Share This Page