iMovie '11 Problem - Not Playing Video

Discussion in 'Digital Video' started by phillf1, Mar 17, 2013.

  1. phillf1 macrumors newbie

    Mar 17, 2013
    Yesterday when I imported some new footage to my iMovie library, I noticed I can't play any videos or open projects anymore. The part of iMovie where the video is shown goes all weird colours (screenshot attached). I've already deleted my cache files and done anything I could find on the internet. Can anyone please help me with it?


    Attached Files:

  2. daybreak macrumors 6502a

    Sep 4, 2009
    Firstly Phill were are you storing your footage? on a external hard drive or your main hard drive.
    Have you tried restarting your computer?. Also do you have any other application open on your dock?
    How much space have you got left on External or main drive.
    These are some of the questions which could help to eliminate your problem.
    Looking from your screen shot too much blood has been pumped into your event folder.
    Hope this helps? no doubt other members can add to this problem.:confused:
  3. phillf1 thread starter macrumors newbie

    Mar 17, 2013

    @daybreaker Thank You for Your replay. I'm storing it on my main hard drive. I currently have around 95 GB free on it.
    Yes, I have tried restarting my computer, but nothing seems to change when I do that. If I'm using a program such as iMovie or FCP X I tend to close everything else.
  4. daybreak macrumors 6502a

    Sep 4, 2009
    I think,your computer is overloaded. Using your main hard drive for video work is not a good idea. All my video storage is on a external drive from iMovie to FCP-X. Are you having the same problem on FCP-X?
    As you well know video files take up a lot of space.
    How much more do you need to do in your project?


    Do you know what clip is causing the problem?
  5. phillf1 thread starter macrumors newbie

    Mar 17, 2013
    I've just deleted all the files, and now I'm importing a few files back. I'll see if it'll work. Going to get an external hard drive as You suggest ASAP. I never get any problems with FCP.
  6. daybreak macrumors 6502a

    Sep 4, 2009
    The picture you posted. I had the same problem once on FCP-X. Like you what the H..... is that.
    It turned out my TimeMachine was working in background and wanted to tell me that i did not have enough space.
    Make sure you buy a good E/Hard drive. The trouble there is so much on the market. I use "MAXTOR" touch wood no trouble.:)
  7. microwebmark macrumors newbie

    Sep 21, 2009
    IMovie 11 is for crap

    Brand New Fresh install of Maverick on MacBook pro IMovie will show that it is recording from my DV tape, (I'm trying to get all my tapes on hard drive to I can be done with tapes forever), and then after the import I find it only did like 3 minutes of recording? I'll rewind.. start at the place it stopped, and boom same thing. only a few minutes. It did not do this for all the tapes at first, but now things are getting worse. started new databases etc. moved movies off the hard drive (but I have lots of space left). I know I'm another poster that offers no advice, but what is a Mac user to do? Call Apple?
  8. montgomeryr macrumors member

    Jan 19, 2012
    LP mode perhaps?

    Is it possible that the footage that is bad was shot in LP mode and transfered on a different brand of camera than the original? There seems to be a standard across brands for SP mode but none for LP. I've encountered this quite a few times and the video breaks up like that in a camera different from the original recorder.

Share This Page