iMovie camera connection

Discussion in 'Mac Basics and Help' started by bryanall, Jan 8, 2011.

  1. bryanall macrumors newbie

    Joined:
    Aug 5, 2008
    #1
    I run a Mac Pro 2 x 2.66 GHz Dual Core Intel OSX 10.5.8 and have been editing video with iMovie HD 5.0.2 for several years. I recently connected my Sony DVR-2100E camcorder to iMovie, imported and edited footage. When I tried to export the edited footage back to the camera iMovie refused to recognise either of my 2 camcorders and would not connect. Although I have iMovieHD installed I do not appear to have iLife. I also have iMovieHD 5.0.2 installed on my Powerbook. When I connect either of my 2 camcorders to the Powerbook they connect OK to iMovie BUT the moment I try to export any footage back to camera it immediately crashes and say's it has lost the connection. This happens every time. If I purchase the Snow Leopard upgrade for Leopard for $39 will it have iLife with a full version of iMovie included, or will I have to purchase a full installation version? I am hoping that a newer version of iMovie with iLife will solve my problems. Can anyone please advise? bva.
     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #2
    You can't share back to a camcorder with iMovie9/11. iMovie6HD was the last one to offer that option.
     
  3. bryanall thread starter macrumors newbie

    Joined:
    Aug 5, 2008
    #3
    Many thanks for that David, looks like i'll have to put my thinking cap on again. bva
     

Share This Page