iMovie cannot import iMovie projects

Discussion in 'Mac Apps and Mac App Store' started by itsmeworld, Sep 5, 2014.

  1. itsmeworld macrumors newbie

    Joined:
    Sep 5, 2014
    #1
    Hi,

    I have the version 10.0.5,

    I edited a video using iMovie then saved/exported/shared it as an MP4 file. However, when I tried importing it again on iMovie, it said 'None of the selected files or folders can be imported. Change the selection and try again. '
    So I tried importing other AVI files, and it worked.
    Then, I tried converting the initial file to an AVI. But when I tried importing it, it said the same thing.

    Can't the new version of iMovie import its own shared files?
     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
  3. somics macrumors newbie

    Joined:
    Sep 11, 2014
    #3
    I also have a new MBA on 10.9 that does not exhibit these issues.
     
  4. Accoustic22 macrumors newbie

    Joined:
    Apr 23, 2018
    #4
    --- Post Merged, Apr 23, 2018 ---
    I was having this issue as well. Initially, I exported the file onto my desktop and then immediately tried to import it back into iMovie and received that error message. I waited a few minutes and received a message from iMovie that my export was successful. I tried imported the exported iMovie again after that message, and it worked. Many this will work for you as well.
     

Share This Page