iMovie clips are Unix executable files

Discussion in 'Mac Apps and Mac App Store' started by josemperezg, Jun 29, 2005.

  1. josemperezg macrumors newbie

    Jun 29, 2005

    I back up an entire iMovie project (Mac OS X) in a PC (Windows 2000 Pro) by dragging and drop the folders and files into the shared windows folder. When I restore the folders and the files by copying again into the shared Mac folder, the original clips appear as unix executable files.

    Is there some way to edit the information of those clips in order to iMovie to recognize them again ?

    Thanks for your help.
  2. Veldek macrumors 68000


    Mar 29, 2003
    Can you "Get info" on these files and set iMovie as the application to open them?
  3. josemperezg thread starter macrumors newbie

    Jun 29, 2005
    It didn't work :confused:

    I also tried to set QuickTime as the applicaton to open them, and it did't work either.

    The iMovie project can be open, and the sounds work fine, but the clips are all black scenes.

    Any other advice?

    Thanks a lot.

  4. bankshot macrumors 65816


    Jan 23, 2003
    Southern California
    Hmm, is the problem simply that they are executable? That seems strange, because why would iMovie care about that? Anyway, to make them non-executable, you can just fire up Terminal, go to the Media folder in the project, and use chmod to remove the executable bits:

    cd "Path/To/iMovie Project/Media"
    chmod -x *
    I just tested using iMovie 4 on Panther, and I don't have any problem with clip files that are executable, so I think this may be a red herring. The reason it happens is that the Mac automatically interprets all files on Windows shares as being executable - this is because Windows doesn't have a concept of executable files vs. non-executable, so in order for unix programs on Windows shares to work correctly, it simply assumes they are all executable.

    My other thought would be that your resource forks somehow got damaged in the copy process. If you used Finder, they should have been preserved on the Windows share as ._FileName, and then copied back into the resource forks when you restore them. HOWEVER - did you do all of the copying from the Mac? If you copied from Windows back to Mac, this would be your problem. The Windows machine knows nothing about resource forks, and therefore it would simply copy the ._Files back as normal files, not as resource forks. All copying must be done from Finder on the Mac.

    Anyway I hope this gives you some more ideas to try.
  5. Linkjeniero macrumors 6502

    Jan 6, 2005
    I think you broke them and there's no repairing them (I could be wrong though). This happens when you move the type of files that are actually a folder with many files inside in Mac OS X (like .apps) to a computer based on another OS. To prevent this, you have to stuff them first.

    EDIT: what he said :)
  6. josemperezg thread starter macrumors newbie

    Jun 29, 2005
    Thank you guys,

    I did broke them. Now I understand that must be more careful in my "back up" process. I copy the files from a windows environment, I didn't use the Finder.

  7. toneloco2881 macrumors 6502

    Jan 23, 2005
    Might be a stupid ? but did you try and change the file extension(.mov,.mpg,etc..) I ask because i had the same thing happen to me with a folder of mp3's. I did the same thing as you, and once copying my files back over from my windows machine they were displayed as unix executables, without any file extension. After i "batch" renamed all of them to include a .mp3 extension, all was well. Just a thought.
  8. Linkjeniero macrumors 6502

    Jan 6, 2005
    It's not the same problem. Yours was just a renaming issue; but iMovie projects are in fact folders with files inside them, and those were lost in the backup (plus, they lost the extension).
  9. anoldmacuser123 macrumors newbie

    Aug 16, 2015
    I know this post is very old, but it still comes up as one of the first results when you search imovie clips and unix executable. I recently (ten years later than the original poster) encountered the same problem. I backed up the files from the mac to windows and was able to restore them on the mac, but the clips (used by imovie) were recognized as unix files on the mac.

    The solution that worked for me was renaming the files with extension ".dv" (for example, clip 01.dv). I hope it works for anyone else who needs it.

Share This Page