iMovie Crashing Problems

Discussion in 'Mac Basics and Help' started by GMANGRIFFG, Oct 17, 2009.

  1. GMANGRIFFG macrumors newbie

    Joined:
    Jun 20, 2008
    #1
    Well, I've been using iMovie for about 1 1/2 years now, and until a couple months back I've had 0 troubles. I'm running iMovie 09 from the new iLife. Works great in every aspect except for importing videos. I've had a Sony Steadyshot HDR-SR11 Camcorder since spring and I upload my videos into iMovie from it. I have 500+ video clips on the harddrive, and, when the import window is open, only the first 20-30 clips have a picture on their thumbnail. When I get down to the bottom of the list, I can't see which clips are which, so I have to double click the clip to see it. I do one just fine, but when I click on the next clip right afterwards, iMovie will normally freeze up and shut down after a couple seconds. This obviously gets very frustrating when I import a lot of clips. I can get through the problem if I take it slow when I click the next clip, but when I do this it takes much longer. Is there any solution to this? I'm thinking I might need to take my clips off the camcorder harddrive and save them on my computer if that will help.

    Nothing too urgent, just a question if i can get some assistance. Thanks for any help I can get :)
     
  2. SchneiderMan macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #2
    This has not happened to me, are you using memory card? is so try importing using the card only and not directly from the camera. im guessing your using the hard drive of the camera?
    Im using a Canon Hf100 hd camcorder with an SD card to import videos.
    If that is not possible, try repairing permissions with disk utility. Other then that i cant help you sorry =/

    Are you running SL? how much ram do you have?
     

Share This Page