iMovie doesn't work in Leopard

ihabia

macrumors newbie
Original poster
May 25, 2007
28
0
italy
I've done a Leopard clean install on my macpro and then added iLife08... iMovie won't start, it crashes at launch. Has someone else noticed the same issue?

ihabia
 

ihabia

macrumors newbie
Original poster
May 25, 2007
28
0
italy
If you added iLife'08 after installing Leopard do a software update.I'm sure you will find several updates for iLife.
I've found the problem.
I had moved iLife apps from the applicaton folder and so I could not find updates.
 
Comment

WantingQu

macrumors newbie
Dec 3, 2007
2
0
My imovie doesn't work either!

I just bought a macbook pro at futureshop. It came with leopard CPU drop-in DVD. I installed it, but somehow I can't open iMovie. Whenever I try to open it, it tells me "The application iMovie quit unexpectedly"

I tried to relaunch the application and restart the computer, it just won't work. Anyone has any idea how to fix this?
 
Comment

WantingQu

macrumors newbie
Dec 3, 2007
2
0
Update

Ok, since my last comment, I was able to get in touch with Apple. And they fixed the problem for me. All I had to do was to run the "Software Update" a few times, and it solved the problem. iMovie works fine now! Thanks to Apple Tech Group! :D
 
Comment

Similar threads

  • stockcerts
3
Replies
3
Views
424
  • Rugbydman
1
Replies
1
Views
287
  • macquestions2
1
Replies
1
Views
623
  • josh bear
5
Replies
5
Views
1K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.