iMovie doesn't work with PowerBook G4s

Discussion in 'Mac Apps and Mac App Store' started by nine, Aug 8, 2007.

  1. nine macrumors newbie

    Joined:
    Jan 6, 2002
    #1
    I just found out the hard way iMovie doesn't work with the Powerbook G4.
    Make sure you know this if you are getting an upgrade & still have a G4.
     
  2. Richard Richard macrumors member

    Richard Richard

    Joined:
    Jun 27, 2007
    Location:
    London
    #2
    sys req for iMovie : # iMovie requires a Mac with an Intel processor, a Power Mac G5 (dual 2.0GHz or faster), or an iMac G5 (1.9GHz or faster).

    well thats just devauled alot of older PMg4 and PB's and even the PMg5's (ie single chips 1.6,1.8 )

    wow big change
     
  3. thworple macrumors 6502

    thworple

    Joined:
    Oct 20, 2005
    Location:
    Sussex, England
    #3
    So... lets get this straight - all apps in the Final Cut Studio 2 Suite, with the exception of Color, run on a Powerbook G4. Yet you can't run iMovie '08 on one?

    Ummmm.......ok.
     
  4. ScottDrummer macrumors 6502

    Joined:
    Jun 27, 2007
    Location:
    Canada
    #4
    what about it you install ilife on a macbook pro for example and copy the imovie folder mannually to the powerbook, and launch it does that work? could be a work around for the installer
     
  5. Richard Richard macrumors member

    Richard Richard

    Joined:
    Jun 27, 2007
    Location:
    London
    #5
    yep that's the bottom line - looks to be Apple's way of slowly doing away with PPC support i guess
     
  6. Richard Richard macrumors member

    Richard Richard

    Joined:
    Jun 27, 2007
    Location:
    London
    #6
    i would think that would not work
     
  7. ScottDrummer macrumors 6502

    Joined:
    Jun 27, 2007
    Location:
    Canada
    #7
    are you able to try it
    my gf is on the way to apple store to buy it, so I will check this out when she gets back
     
  8. thworple macrumors 6502

    thworple

    Joined:
    Oct 20, 2005
    Location:
    Sussex, England
    #8
    Yeah, I don't disagree with you there - but in that case why not make the entire suite incompatible with the Powerbook G4?

    It seems ridiculous that Apple's less complex video editing app won't work on older machines, when the professional edition will! I'm not too fussed personally as I use FCP anyway, but it just seems weird to me.
     
  9. DinoMac macrumors newbie

    Joined:
    Dec 28, 2005
    Location:
    Atlanta
    #9
    I was about to pick up iLife08 after work today for my last Gen PowerbookG4. Now after reading this, I am having second thoughts. :mad::mad::mad:!!!
     
  10. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #10
    i installed iLife 08 on my last gen powerbook last night... negative on the iMovie. it's crazy that i can run final cut pro, motion, and other professional software on here... but not freakin' iMovie. makes no sense.

    think someone will figure out a way to install it on powerbook G4s anyway? perhaps there's some sort of work around...
     

Share This Page